System doesn't boot after update

After the computer boots up it shows the following picture:

This happened after a system update, which was unfortunately interrupted. What should I do in this terminal there?

1 Like

open tty2
pacman -Syyu (see if that fixes anything)
pacman -S linux-headers

also try booting into the live usb and running lsblk, send me the output.

refer to this thread - Failed to start Load Kernel Modules - #24 by The_Quantum_Alpha


pacman -Syyu gives something like this:

Error: Could not update core (Cannot lock database)
Error: Could not update extra (Cannot lock database)
Error: Could not update community (Cannot lock database)
Error: Could not update multilib (Cannot lock database)
Error: Error at synchronizing all databases

and pacman -S linux-headers gives this output:

Error: Could not start process (Cannot lock database)
Error: Could not lock database: the file already exists
If you are sure that a package manager is not running yet, you can remove /var/lib/pacman/db.lck

Use this as a reference.

Also use the solution in that thread, it may or may not help you.

Okay, I’ll take a look at it thanks for your help.

After booting live ISO and manjaro-chrooting try

sudo rm /var/lib/pacman/db.lck
sudo pacman -Scc
sudo pacman-mirrors -f && sudo pacman -Syyu

I tried the threads’ solution and it worked - without using a live iso! I could successfully install the new kernel in the terminal. Thank you!

Hello Nalesframe,

CAn you please tell me what was what you did???

I had similar problems after update Failed to start Load Kernel Modules.

I have tried live usb with

sudo manjaro-chroot -a 
pacman-mirrors --continent
pacman -Syyu

and it did not work.


I mentioned a thread earlier, he used that.

Yeah I used the 16. answer of The Quantum Alpha and it worked perfectly. But I didn’t even had to use a live usb, I used a terminal which was available there when I booted.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.