System does not boot with 5.10 kernel

5.9 kernel boots again after reinstalling it. But 5.10 does not…I think I’ll wait for next release.

The same happened to me. I also tried sudo update-grub and also remove and re-install kernel 5.10. but after rebooting I keep using 5.9 kernel.

I am on kernel 5.10.1-5 / Gnome / Radeon RX 5500 XT MECH 8G OC
WORKING perfectly…

Same problem with integrated amd gpu. I found a temporary solution to be able to boot the kernel by adding amdgpu.dc=0 to the GRUB boot line.
I found this solution in the arch forum.

Sorry for my English


I am still having this same issue, though I just updated into 5.10.2-2 . I will wait for next release I guess… I’ve no idea what can cause it…I will keep running 5.9

1 Like

Same problem got here with an amd hp laptop, on another lap, an old hp with intel graphics 3000 linux510 has no problems at all, with the first one I can only boot on linux59.

Thanks for the tip, I’ll try later that!

I reinstalled the newest GPU-Driver and now it works.

After upgrading to the 5.10 kernel, Manjaro no longer starts. I am writing from another computer. I have read that adding “amdgpu.dc=0” solves it, but I am not a computer scientist and I don’t know where to add those parameters.
When I start the computer by pressing the ESC key I have two options:

  • Manjaro Linux
  • Advanced options for Manjaro Linux

Neither option starts Manjaro

If I select the last option, I am presented with four choices:

  • Manjaro Linux (kernel 5.10.2.-2-MANJARO x64
  • Manjaro Linux (Kernel 5.10.2-2 MANJARO x64 - fallback initramfs
  • Manjaro Linux (Kernel 5.9.16-1-MANJARO x4
  • Manjaro Linux (Kernel 5.9.16-1-MANJARO x64 - fallback initramfs

None of the four options starts Manjaro.

When I select EDIT in these options a number of parameters appear that I do not understand at all.

I have also read that the 5.10.3 kernel seems to have fixed this bug, but how do I install that kernel if I can’t boot Manjaro?

Please help!
Thank you very much.

Hi, I had the same issue 20 minutes ago after accepting a big update. After the update was done I booted but got stuck and couldn’t do any form of rescue because my keyboard not longer responded.

Best for you to do now is boot (hard reset, press power button for n seconds), escape to grub and fall back to a previous kernel. In my case 5.9 which boots fine.

For now I uninstalled kernel 5.10.2-2 until I, or someone, figures out what’s happening. I have not found a resolution currently. Good luck!

Hi blackSP
Thank you for your help.
I tried to reboot with kernel 5.9.16-1 but it did not start too.
I have not any kernel 5.10 file on my system, in spite of I updated it. It’s all very strange.

Same thing here, during the big update from yesterday, there was a remark that the 5.9 kernel was no longer supported and that I should install the 5.10 kernel.
But after installing it, sddm no longer works when using the 5.10 kernel.
When I select the 5.9 kernel it works though.
So I guess there may be a packaging error in the 5.10 kernel package.

It would be good if the devs signal in this topic, when it has been solved.

It seems the solution already arrived.
In Pamac, I clicked on refresh databases, and after that finished, I got a new update notification, for sddm and Manjaro system.
After that no more boot problems with kernel 5.10.

1 Like

Hats off, good friend. This allows me to boot linux 5.10 on a HP Laptop with an (integrated graphics) AMD chipset. It was booting 5.9 just fine, like the OP’s description.

Thanks for your tip.

Latest updates did not give problems anymore. Thanks Manjaro devs!

current kernel in testing is: 5.10.4-2
Running well.

Pressing ctrl+alt+f2 does it give you terminal login?

I think he/she is no longer interested in that.
Posted multiple times in different threads, such as here - but has since stated that the system was already reinstalled.
Now has a different problem - accessing the Deja-Dup backup.

Okay thanks for the info.