System crashed during update and cannot chroot to fix things

The grub boot instruction got corrupted too but thankfully I can still boot grub itself if I load the drive manually, I’ve seen threads that mention a potential fix for that but they always require chroot. I originally tried the

su -

in a normal terminal (of live usb) and then followed the instructions I’d found but fell short at the

chroot /mnt/lbl/@ /bin/bash

I tried many variations thereof but no luck so I then went to the actual directory, opened it as root and then opened it in terminal then finally tried the chroot variations again but instead used variations of . ./bin/bash, unfortunatly all I get is messages like this:

chroot: failed to run command ‘./bin/bash’: Input/output error

I checked in the relevant directories and they ARE there so I’m now at an impass, someone please help me

I think the chroot command in manjaro is just

manjaro-chroot -a

I restored my grub/uefi partition using the guide on the wiki

Yeah I’ve tried manjaro-chroot too, didn’t work, switched to chroot afterwards to see if anything changed but as you can see I’m here

Edit: Btw when I tried the -a command it keeps going for the wrong drive so I gave up on that

Edit 2: to be exact it chucks this at me:

grub-probe: error: cannot find a GRUB drive for /dev/sde1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sde1. Check your
==> ERROR: No Linux partitions detected!

Found a page of instructions for grub mode that I’m gonna try, I’ll have to reboot so expect it to be a while before any responses

Had to sleep so attribute a few hours of the wait to that, I’ve somewhat restored grub I think as the instructions were about a generic system boot fix from livecd/liveusb. Unfortunately I still can’t get the system to boot as the kernels appear to be corrupted. The files still exist, I tried xnu_kernel & xnu_kernel64 on the file in /@/boot but they report Mach 0 is not setup for 32/64bit. I tried the linux command on those same files but it reports premature end. I don’t actually know what those commands do but I figured they look suitable, honestly I think the system is confused by the /@ that should be prepended to the root but I don’t see it when it says it can’t find the kernel files from the grub menu

any ideas from that?

If you can chroot into your system can you update it from there with pacman-Syu ? It should fix the kernel

No go, grub doesn’t have a chroot command as far as I can tell, liveusb doesn’t want to allow it either reporting io error but doesn’t ellaborate

You can use chroot and mhwd to install a kernel through cli that should give you a working kernel plus it will also update grub as well

How many times do I have to say that chroot refuses to work, it is not an option

Gave up and reinstalled manjaro after downloading a new iso, on a side note love the new style of the boot interface

I didn’t see it mentioned, but …
you did try to chroot into your system via booting from USB (or similar) ?
From the syntax you used I suspect your system is on BTRFS ?
… which might … complicate things
oh well - it’s done with now …

It’s in literally my posting msg

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.