System consumes keyboard shortcut


VSCode has a default shortcut for copying a line up or down: Ctrl+Shift+Alt+Up/Down.
The combination of Ctrl+Alt consumes the up/down key.
I guess this is because Ctrl+Alt+directional key is used for moving a window the workspace left/right/above/below the current one.
But the system settings (Settings»Keyboard»Customize Shortcut) show only keyboard shortcuts for moving windows left and right. Maybe because my workspaces are “horizontally aligned”.

How can I disable the system shortcut, so that it doesn’t get consumed by the system and get passed through to VSCode?

Is there a terminal programm to check what was bound to a specific shortcut/key combination?

Are there other configuration files/possibilites than those of the settings UI I could check?

There is the dconf editor to check/edit the keybindings.

They are in /org/gnome/desktop/wm/keybinding/

There is indeed a option for your specific issue if I understand it correctly:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.