System asks for ctrl+d after grub selection at boot; why?


#1

Hi everyone,

installed manjaro xfce on my hp pavilion dm 1-3020us pc and its been wonderful so far. its just that after selecting manjaro from grub (dual boot with win 7) i have to do a ctrl+d before manjaro loads, can anyone help in removing this issue.

Tips for posting

Use a “keyword search” to make sure your question has not already been asked. For example “failed to verify key” or “sound is muted”.

Make sure you include enough detail so people know what you are running. A useful command is inxi -Fxz; copy and paste the text and format as “code” (e.g. use the </> button above).

If possible, paste text rather than upload a photo. Text is easier to read, searchable, and takes up less space on the server. Please don’t upload high-resolution photos.

For more information read this post: How to provide good information in your posts

Remember to remove all of this help text before you post.



#2

1st message, you have an external drive plugged-in.
2nd message, you installed GRUB incorrectly.

How did you burn the LiveISO? What utilities and procedures?

regards


#3

What’s cat /proc/cmdline at the terminal?
And provide grub menuentry of /boot/grub/grub.cfg (the first entry will do).


#4

i used the usb writer tool of linux mint 17.3 on my other laptop to make the liveusb, then used it to boot on this laptop and install manjaro. Its this microsd card which is the external drive shown as 1st message.


#5

cat /proc/cmdline =

BOOT_IMAGE=/boot/vmlinuz-4.14-x86_64 root=UUID=ce078426-6aea-4ef1-a6b1-7add29a88fc5 rw quiet Spa .off = 1

grub.cfg menuentry

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="${saved_entry}"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

set menu_color_normal=light-gray/black
set menu_color_highlight=green/black

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos4'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  ce078426-6aea-4ef1-a6b1-7add29a88fc5
else
  search --no-floppy --fs-uuid --set=root ce078426-6aea-4ef1-a6b1-7add29a88fc5
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_IN
  insmod gettext
fi
terminal_input console
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='hd0,msdos4'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  ce078426-6aea-4ef1-a6b1-7add29a88fc5
else
  search --no-floppy --fs-uuid --set=root ce078426-6aea-4ef1-a6b1-7add29a88fc5
fi
insmod png
background_image -m stretch /usr/share/grub/background.png
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-ce078426-6aea-4ef1-a6b1-7add29a88fc5' {
	savedefault
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos4'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  ce078426-6aea-4ef1-a6b1-7add29a88fc5
	else
	  search --no-floppy --fs-uuid --set=root ce078426-6aea-4ef1-a6b1-7add29a88fc5
	fi
	echo	'Loading Linux 4.14.47-1-MANJARO x64 ...'
	linux	/boot/vmlinuz-4.14-x86_64 root=UUID=ce078426-6aea-4ef1-a6b1-7add29a88fc5 rw  quiet Spa .off = 1
	echo	'Loading initial ramdisk ...'
	initrd	/boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
}
submenu 'Advanced options for Manjaro Linux' $menuentry_id_option 'gnulinux-advanced-ce078426-6aea-4ef1-a6b1-7add29a88fc5' {
	menuentry 'Manjaro Linux (Kernel: 4.14.47-1-MANJARO x64)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.47-1-MANJARO x64-advanced-ce078426-6aea-4ef1-a6b1-7add29a88fc5' {
	savedefault
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos4'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  ce078426-6aea-4ef1-a6b1-7add29a88fc5
		else
		  search --no-floppy --fs-uuid --set=root ce078426-6aea-4ef1-a6b1-7add29a88fc5
		fi
		echo	'Loading Linux 4.14.47-1-MANJARO x64 ...'
		linux	/boot/vmlinuz-4.14-x86_64 root=UUID=ce078426-6aea-4ef1-a6b1-7add29a88fc5 rw  quiet Spa .off = 1
		echo	'Loading initial ramdisk ...'
		initrd	/boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
	}
	menuentry 'Manjaro Linux (Kernel: 4.14.47-1-MANJARO x64 - fallback initramfs)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.47-1-MANJARO x64-fallback-ce078426-6aea-4ef1-a6b1-7add29a88fc5' {
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos4'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  ce078426-6aea-4ef1-a6b1-7add29a88fc5
		else
		  search --no-floppy --fs-uuid --set=root ce078426-6aea-4ef1-a6b1-7add29a88fc5
		fi
		echo	'Loading Linux 4.14.47-1-MANJARO x64 ...'
		linux	/boot/vmlinuz-4.14-x86_64 root=UUID=ce078426-6aea-4ef1-a6b1-7add29a88fc5 rw  quiet Spa .off = 1
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initramfs-4.14-x86_64-fallback.img
	}
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 7 (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-185A36665A3640B4' {
	savedefault
	insmod part_msdos
	insmod ntfs
	set root='hd0,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  185A36665A3640B4
	else
	  search --no-floppy --fs-uuid --set=root 185A36665A3640B4
	fi
	parttool ${root} hidden-
	chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

### BEGIN /etc/grub.d/60_memtest86+ ###
if [ "${grub_platform}" == "pc" ]; then
    menuentry "Memory Tester (memtest86+)" --class memtest86 --class gnu --class tool {
        search --fs-uuid --no-floppy --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  ce078426-6aea-4ef1-a6b1-7add29a88fc5
        linux16 /boot/memtest86+/memtest.bin 
    }
fi
### END /etc/grub.d/60_memtest86+ ###


#6

Do what the message says:
After logging in, run journalctl -xb
Since the system works, Grub should be fine. The system(d) is already “in control” when the message appears.
Make sure you are full updated.


#7

As petsam says.


#8

not that it doesnt help but what exactly will it accomplish, i still have to either do ctrl+d or give root password and “systemctrl default”. I am hoping for a seamless transition from grub choice to the os desktop.


#9

Most likely a graphic driver issue.
What’s

mhwd -l
mhwd -li

#10
> 0000:00:01.0 (0300:1002:9802) Display controller ATI Technologies Inc:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
        video-catalyst            2017.03.12               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:01:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
        video-catalyst            2017.03.12               false            PCI
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI


Warning: No installed USB configs!

#11

Right. You’re using catalyst drivers.
You should use ‘free’ drivers, namely ‘video-linux’.
Catalyst drivers conflicts with xorg-server version used in the OS.

Some have experienced difficulties in changing from catalyst (or worked out how to use catalyst) and I am not proficient enough to guide you on how to do it. Hope others can help you on this. But if there is no response after waiting some time, here’s what I did some time ago and old method worked for me. There’s a new method now (–setmod). But if others jump in, listen to them,

Boot into prompt {add ‘3’ to linux line in grub parameter, login in with password} and do the following commands

sudo mhwd -r pci video-catalyst
sudo pacman -Syu
sudo mhwd -i pci video-linux
sudo pacman -Syu
sudo mhwd-gpu --setmod

Good luck.

ps: do the ‘pacman -Syu’ 2 times to get the xorg-server correct.
ps: then see if you do without the ‘Spa .off = 1’ in the grub parameter after that.


#12

all right screwed, now system wont load, checked wiki, need internet connection to reinstall video driver, how to enable internet from terminal and reinstall basic video drivers


#13

At grub menu, press 'e’
Arrow down to linux line
Arrow right past ‘quiet’ and 'splash’
Backspace to remove ‘quiet’ and ‘splash’ taking care not to remove 'rw’
Add ‘3’ (without apostrophes meaning just 3)
Press F10 or ‘ctl’ + ‘x’ to boot

login with password to prompt.

Then fix your graphics.

If you still cannot fix your graphic card drivers, reinstalling may be easier.

[edit] - always check if your internet is working.
May not be working even with a ‘good working’ OS. Reboot to get internet working.
It’s been some time they haven’t got this working reliably and consistently.


#14

Or live Cd and manjaro-chroot into system if you don’t want to lose state.
How to save your Manjaro installation when it breaks


#15

thanks for this article, it helped in restoring my pc back to square 1, learnt some new tricks too.


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.