/sys/firmware/efi/efivars: unknown filesystem type 'efivars'

I just rebuilt the 50-rt kernel with CONFIG_EFI_VARS=y , but I still see the same EFI message … :thinking:

Nah, no worry mate. I thought it was a grub related problem back then and I know you’re the grub guru back in the days so I quoted you :smile:
Happy for you to enjoy your holiday :slight_smile:

Yeah I tried that one and still got the error message

Oberon confirmed that enabling CONFIG_EFI_VARS doesn’t suppress the error :frowning_face:

There’s nothing happening at all, it’s just my real life is now too busy with my work. And my energy is drained after work, so I prefer sitting on the couch play some games watch some movies instead of reading people’s ranting about their problem with Manjaro here :smile:

It’s been a long time no see, mate. Hope you’re doing fine :smiley:

Yeah I think there’s something going on with linux-rt. Maybe this is upstream bug? Like I insisted before my machine was installed in UEFI mode for sure but Linux-rt can’t mount the efivars correctly. Maybe because the kernel should mount efivarfs instead of efivars?

Yeah the kernel boots fine without problem, but system is definitely not in UEFI mode. And my brain couldn’t stop thinking about it every time I see that message :stuck_out_tongue:

In any case the issue looks like not related to any of our config since the regular kernel doesn’t display the problem.
Maybe would you like to post in the rt-kernel mailing list?
linux-rt-users@vger.kernel.org
You have to subscribe somehow before you can actually post to it - I don’t remember right now how the procedure was, but I think @crazyg4merz back then you were already a member anyway…

okay I’ll do it and post back when I’ve got their reply

1 Like

I just saw Sebastian’s reply on the rt-mailinglist.
He suggests adding efi=runtime to kernel parameters.
Seems to work for me. :sunglasses:

3 Likes

Sorry if this is out of my league, but both are there?

    CONFIG_EFI=y
    CONFIG_EFI_VARS=y

Cheers.

Yes, I have tried with both enabled.

1 Like

Yeah, I just tried putting that in the grub boot options and the message disappeared! What make me wonder is why does this doesn’t happen on the normal kernel though. Any idea? But I can live with this though, my boot is clean now :slight_smile:

Update: I just got a reply from Sebastian, the EFI runtime is disabled by default in RT kernel because it can cause latency issue. And it’s disabled by this patch: efi-Disable-runtime-services-on-RT.patch
So I think I can mark this as solved. Thanks guys :slight_smile:

2 Likes

WELCOME BACK! :grinning:

1 Like

Just asking. Why is this an issue? Disk latency rather than network latency, right? milliseconds?
For example, 6G is not significant for its 1000 times faster than 5G, rather for its latency improvements critical in say, driverless automation or hypersonic manoeuvrability but why is this important for RT kernels?
Thanks.

Hello, glad to see you again kouros :wink:

Because Realtime kernel is all about latency, that’s why it’s called realtime :smile:
It’s important in RT kernel because those latency will affect the way your audio server performs. The idea of having RT kernel is to achieve as little latency as possible yet getting as little Xruns (audio stutter in Jack server) as possible.

2 Likes

Thanks. Excellent explanation. Cheers.

hello guys , so recently i update my kernel to rt 5 and have same error message after boot to manjaro and just curious how can i edit that parameter to enable efi runtime? already google it but cant find any forum that discuss how to do that

It's a kernel parameter:

https://wiki.archlinux.org/index.php/Kernel_parameters#GRUB

If you need more help please start your own thread rather than hijacking a Solved thread.

Hi @BlackMagic. I have edited my /etc/default/grub to contain this:

GRUB_CMDLINE_LINUX_DEFAULT="efi=runtime quiet resume=UUID=aa4d27e9-c3fe-44f7-a31e-257bd53a268b

the ran sudo update-grub
That's it.

1 Like

I uesd to use kernel 4.19,there is no such problem but when i update my kernel into 5.0 then i have the same problem. the reason why I update it is using 4.19 would cause the system crash sometime but 5.0 is no such problem. thank you and your team for providing such a great linux distribution

Forum kindly sponsored by Bytemark