/sys/class/backlight folder is empty and there is no backlight control

Hi,

I’ve been using Manjaro for about 8 months now on my custom Framework Laptop (which IIRC is from the 3rd batch that got made in September, 2022). I’ve been relatively happy with it, but have recently run into some issues after not using my laptop as much as usual at the start of this year. Right now I’m having issues controlling my backlight both from the keyboard hotkeys (and the airplane mode key on my laptop). So here is the relevant timeline for this issue.

  • I installed Manjaro on 10/11/22, and initially my backlight keys on my keyboard were not working. I eventually found the fix, which I believe was from blacklisting the ALS by creating a file in /etc/modprobe.d/.

I went for a few months without the system upgrading (which I know is stupid for a rolling release) and was faced with the conundrum of needing to update the signatures in order to update my system, but also needing the updated system to update the signatures. Eventually I temporarily decided to trust all signatures to update the system and then once the system was updated I changed back to requiring signatures. The update was successful, but I lost control of the brightness keys again (although I could still control the brightness from the system). This was on 5/16/23.
I also updated the firmware of my laptop, and upon reboot I lost all control of brightness. Where there used to be a /sys/class/backlight/intel_backlight directory, now /sys/class/backlight/ is empty, and I can’t find anything on how to get the backlight control back. I don’t know if it has anything to do with a kernel update or a system update, but whereas in the System Settings on KDE Plasma before I could adjust the brightness levels for different power levels (Plugged in, on battery, low battery), now that option does not exist. I am having trouble finding a solution, as the latest I can find for any solution is from 2016. I really want my backlight control back.

Attached is the output from inxi -Fxz. Let me know if I should attach anything else.

    ~  inxi -Fxz                                                                                      ✔ 
System:
  Kernel: 6.3.3-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: KDE Plasma v: 5.27.4 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Framework product: Laptop (12th Gen Intel Core) v: A4
    serial: <superuser required>
  Mobo: Framework model: FRANMACP04 v: A4 serial: <superuser required>
    UEFI: INSYDE v: 03.05 date: 08/23/2022
Battery:
  ID-1: BAT1 charge: 43.2 Wh (83.7%) condition: 51.6/55.0 Wh (93.8%)
    volts: 17.5 min: 15.4 model: NVT Framewo status: charging
CPU:
  Info: 12-core (4-mt/8-st) model: 12th Gen Intel Core i5-1240P bits: 64
    type: MST AMCP arch: Alder Lake rev: 3 cache: L1: 1.1 MiB L2: 9 MiB
    L3: 12 MiB
  Speed (MHz): avg: 1736 high: 2751 min/max: 400/4400:3300 cores: 1: 1746
    2: 2100 3: 1059 4: 1804 5: 1726 6: 2100 7: 2751 8: 2100 9: 2100 10: 1135
    11: 1161 12: 2100 13: 902 14: 2100 15: 2100 16: 807 bogomips: 67600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
    arch: Gen-12.2 bus-ID: 00:02.0
  Device-2: Realtek Laptop Camera driver: uvcvideo type: USB bus-ID: 3-7:3
  Display: wayland server: X.org v: 1.21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_wayland driver: X: loaded: modesetting dri: iris gpu: i915
    resolution: 2051x1367
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3
  API: ALSA v: k6.3.3-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.70 status: off
  Server-3: PulseAudio v: 16.1 status: active
Network:
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    bus-ID: a6:00.0
  IF: wlp166s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB
    bus-ID: 3-10:5
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 931.51 GiB used: 188.09 GiB (20.2%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T3X0C-00SJG0
    size: 931.51 GiB temp: 39.9 C
Partition:
  ID-1: / size: 915.53 GiB used: 188.09 GiB (20.5%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 323 Uptime: 31m Memory: available: 31.06 GiB
  used: 4.64 GiB (14.9%) Init: systemd Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: 1588 Shell: Zsh v: 5.9 inxi: 3.3.27

Known issue on distros with newer kernel versions. The page also describes what to do, albeit in Fedora specific manner. So instead, do the equivalent in a distro agnostic way (the video author uses Gentoo, but what he showed is applicable in basically every distro that uses GRUB.

1 Like

That did it thanks!

For those wanting written instructions, here is the process:

Open /etc/default/grub in a text editor and add the parameter module_blacklist=hid_sensor_hub (this disables the ambient light sensor) inside the quotes to GRUB_CMDLINE_LINUX_DEFAULT="[quiet splash other_parameters]". Mine looked like this:

GRUB_CMDLINE_LINUX_DEFAULT="udev.log_priority=3 splash module_blacklist=hid_sensor_hub"

Then reconfigure the GRUB config file

grub-mkconfig -o /boot/grub/grub.cfg 

And then reboot. This fixed the problem for me. I also deleted the file that I thought would do the same thing in /etc/modules.d/ and things are back to normal.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.