Sync/Transfer music to phone with Strawberry

I try to sync my music from Manjaro to my Android phone. At least a playlist including the songs on this specific playlist. For this, i have installed Strawberry, since i can maintain my music perfectly with this application. I have tried other applications to, but since it is required to sync play statistics from ( back to the library, i have found that only strawberry can do exactly this.

But now i cant sync the playlist from strawberry to my phone. If i connect the phone via USB, it is visible as device in strawberry, but i cant access it. According to my research, it has something todo with mtp only allowing one device/aaplication to be active at the moment. But the phone seems to be mounted directly after plugging in. But also when i unmount the phone from within “Files”, the sync from withtin Strawberry didnt work.

Can someone please help me to make the sync of playlists and tracks inside the list working with Strawberry?

Many thx for the HowTo. With that, i can use the Phone at least via the filemanager. But if the phone is mounted there, as described by the HowTo, the phone access is blocked in Strawberry. If i unmount the phone again in filemanager, Strawberry can access the phone again. But ckopy a track to the phone hangs and no files/songs are copied.

According to this thread, Make sure the phone isn’t mounted, if it’s mounted it will block access. Then it should be possible to connect it by double clicking under devices. You should be prompted on the phone once connected if you want to transfer files, make sure that you select it in time.

Yes, thats what i have subscribed, based on reading the exact same thread :slight_smile: But also, when i use the described way, i cant transfer the songs. I cant see any error message. I see only that the process seems to take for ever or is stuck somehwere.

I have hoped, that someone which uses Strawberry, has a solution or idea.

I am just guessing but can you check if the usb is controlled by your pc/connected device and not your phone/this device.

If i look on Android phone, i can see that the connection set to be controlled by the phone and not the desktop. If this is what you mean. I cant change, because i get a error message on the phone, when i try that. I have no idea how to succesfully change this setting.

See this thread to control android device:

Also make sure you have gvfs-mtp package and enable file transfer on your phone. Swipe from the top of the screen - use the notification to enable file-transfer - the default is charging.

Jepp, package is installed. Working fine with file-manager, but again… not Strawberry :frowning:

Maybe, it will help to open a issue on Strawberry Github, I will try that.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.