Symlinks and creating new folders, both with Dolphin

It has been some time since I have used Linux seriously. (I used to use Slackware.)

First, I cannot create a symlink with Dolphin (nor using a terminal - as root or not). Regarding Dolphin I copy the actual folder by dragging the actual folder while holding Ctrl+Shift. I then type in the symlink alias. This doesn’t work.

(For those who will tell me to use a terminal, I used this “ln -s actualpath aliaspath” and get an error message that the path doesn’t exist. The actual path does exist! I had thought (and this worked years ago) that the symlink path was simply an alias.)

With regards to creating a folder, first I know how to create directories (folders) in a terminal, I would like to be able to do this in Dolphin (or some other gui file manager). I do have access to root actions by right clicking on the client window. Create folder is not one of the options.

Thank you

To be more correct, it would be
ln -s /actualpath/file_or_filder /actualpath/file_or_folder
and if you are doing it in the system files/folders then
sudo ln -s /actualpath/file_or_filder /actualpath/file_or_folder

Via Dolphin drag and drop, you can do it on the places where you have write permissions, your home directory. Just by left click drag and drop you will get this menu:


Root Actions was diminished in functionality and in most cases removed, and firmly discouraged to be used. Most administration tasks use polkit this days.
Maybe this will help you out:

1 Like

Thank you for your reply. You are of course correct about the details of ‘ln’, and I am trying to create a symlink for a subfolder of usr. I need it inorder to install WordPerfect 8 for linux. (It assumes a path and folder that is no longer used.) In the end it isn’t working even when I am logged into the terminal as root.

I tried your symlink method in Dolphin, however I have insufficient access.

‘polkit’ is new to me, at least I don’t remember it.

Nautilus appears to not allow me to create a symlink.

  1. I doubt whether that will still be compatible with today’s system libraries. That software is over 20 years old and no longer maintained ─ the 8.1 version that succeeded it didn’t even natively run on GNU/Linux anymore but instead required wine, because it was a Windows-only version.

  2. The FHS dictates that software which is installed outside of the scope of the package manager should go under /opt if it is distributed by its makers in a binary form ─ in which case it’ll commonly come either with its own installer script or else as a self-extracting archive ─ and under /usr/local if it is installed by locally compiling and linking the source code.

polkit (or formerly policykit) is a privilege mitigation framework for use in GUI environments. Most of the KDE software ─ e.g. Dolphin, Kate, KWrite, et al ─ is polkit-aware and will prompt you for the root password (or your own password if you have sudo access) if you plan on writing to an area of the directory hierarchy that your regular user account normally has no write access to.

1 Like