Switching to Nvidia GPU kills Wi-fi

Hello,

I installed Manjaro KDE in a brand new MSI Modern 14 A10RB. I then installed the Nvidia corresponding driver, and optimus-manager to switch between my Intel integrated graphics card and my Nvidia GPU (Geforce MX250).

System:    Host: sergi Kernel: 5.4.44-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: Modern 14 A10RB v: REV:1.0 serial: <root required> 
           Mobo: Micro-Star model: MS-14B3 v: REV:1.0 serial: <root required> UEFI: American Megatrends v: E14B3IMS.50C 
           date: 10/31/2019 
Battery:   ID-1: BAT1 charge: 51.6 Wh condition: 51.6/50.0 Wh (103%) model: MSI BIF0_9 status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake rev: C L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 791 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 799 
Graphics:  Device-1: Intel UHD Graphics vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP108M [GeForce MX250] vendor: Micro-Star MSI driver: nvidia v: 440.82 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce MX250/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: Logitech [G533 Wireless Headset Dongle] type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2 
           Sound Server: ALSA v: k5.4.44-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3 
           IF: wlo1 state: up mac: c0:b8:83:f2:23:71 
Drives:    Local Storage: total: 476.94 GiB used: 46.88 GiB (9.8%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 476.94 GiB 
Partition: ID-1: / size: 468.16 GiB used: 46.88 GiB (10.0%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A gpu: nvidia temp: 55 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 249 Uptime: 46m Memory: 15.48 GiB used: 1.79 GiB (11.6%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.17 inxi: 3.0.37 

When I switch to the Nvidia GPU with optimus manager, I found out a very strange behaviour... I cannot connect to my home Wi-fi when I have my Nvidia GPU turned on.

When I go back to my Intel card though, the connection is as smooth as always (and the connection works perfectly for other devices in my home). I've tested this dozens of times just to make sure of what I'm saying.

To make things weirder... I tried to connect to my phone using a Wi-fi share point (so my phone was sharing the 4G internet connection to the laptop) and, to my surprise, the computer DOES get connected to the network.

Two more comments:

  • The optimus manager 'hybrid' setting is not working, so whenever I have tried to switch to Nvidia, I've done it with 'nvidia' setting.
  • The Wi-fi home connection actually worked once while the Nvidia GPU was activated. Don't know the explanation to this but it turned out to work that one particular time without me changing anything. In general, the computer finds the network and tries to connect to it but is not able to download or upload any data.

My questions are:

I don't know if the problem comes from my system, from optimus manager, from my GPU...? Is this usual? Is this an expected thing to happen when dealing with similar situations? How to fix it?

Sounds strange so my further comment is - by nature - highly speculative.

I am not aware there should be any connection between the gpu whether internal or external - what may be - taking into account the laptop doesn't loose network - is that some applications in /xdg/autostart or ~/.config/autostart is not started as the switch does not involve a complete restart of the system - only restart of specific services related to gpu switching.

Thank you for your answer. If this was the case, would would you try to do?

By the way I've rebooted the computer so I'm not sure this can occur. Is there a world where this behaviour is killing these autostart applications even upon rebooting?

I would take a look at this page at the Arch Wiki

I would activate the Nvidia GPU then use the terminal to troubleshoot - maybe disable network manager and use either connman or systemd to handle network. (With systemd you need to use iw or iwd)

It is really strange what you say - that tethering using your phone's wifi hotspot works but your usual home connection do not and reading on the mentioned wiki I got the thought that crda could be misconfigured - but yet again there is too many unknown variables.

As you can see I don't have a lot of ideas of what is going on.

I will take a look and consider your indications. Thank you for your help.

Forum kindly sponsored by