Switch back to Wayland doesn't work (worked fine before)


I was using Wayland in default config and it worked fine until this morning. To test something I switched to linux60 and linux61 this morning, but I had problems with the built-in notebook screen. Then I switched to X11 to see if that would help, but it didn’t.
Unfortunately now I’m not able to switch back to wayland.

I only modified the /etc/gdm/custom.conf file and uncommented the #WaylandEnable=false line, as described in the ArchWiki https://wiki.archlinux.org/title/GDM#Use_Xorg_backend.
Adding the comment back and rebooted didn’t help.
echo $XDG_SESSION_TYPE still shows x11.

I am using a Dell Latitude 7430 notebook with an Intel Alder Lake CPU. So no NVIDIA involved.

CPU: 10-core (2-mt/8-st) 12th Gen Intel Core i7-1265U (-MST AMCP-)
speed/min/max: 465/400/4800:3600 MHz Kernel: 5.15.84-1-MANJARO x86_64 Up: 18m
Mem: 3443.1/31535.3 MiB (10.9%) Storage: 953.87 GiB (11.6% used) Procs: 343
Shell: Zsh inxi: 3.3.24

When checking the logs (journalctl -b | grep -i wayland) I am seeing the following:

Running GNOME Shell (using mutter 43.2) as a Wayland display server
(EE) could not connect to wayland server
Starting GNOME Shell on Wayland...
org.gnome.Shell@wayland.service: Skipped due to 'exec-condition'.
Condition check resulted in GNOME Shell on Wayland being skipped.

Full log: https://pastebin.com/PQvZyDpU

Any ideas what I could try to get back to wayland?


How did you do that?
From what I remember, it is a choice you make at the login screen. GDM.

The option only appears once you have chosen a user name to log in as, but before you enter the password.

That’s quite easy, just uncomment the #WaylandEnable=false in /etc/gdm/custom.conf and reboot. Described here https://wiki.archlinux.org/title/GDM#Use_Xorg_backend

I only see the options “GNOME” and “GNOME Classic” there.

I have no other bright idea - someone else might, though.

I only have Gnome in a virtual machine where wayland isn’t even an option - AFAIK.

only found this:

Configuring Xorg as the default GNOME session :: Fedora Docs