Sway ARM version doesnt open wm, [Sway: cannot start: libseat: Could not activate session: Permission denied]

This error (output: 4 to 5 lines long, I forgot the rest of the error) happened after booting Manjaro ARM Sway USB drive on my raspberry pi

Sway: cannot start: libseat: Could not activate session: Permission denied

Solution: sudo pacman -S polkit
This only works when creating a booting device with Manjaro ARM Minimal in it, then you have to install sway and polkit aka policy kit.

Please devs

  • Include the ‘polkit’ package inside of “Manjaro ARM Sway Edition”, that way the bug ends up solved.

PD: JESUS CHRIST, THE “+” button to create a new post it’s so hidden when activating darkmode with Dark Reader, please make a written button saying “Create Post” at the top of a topic please, It was a pain trying to create this post, 10 minutes wasted for one simple thing

There is a button with text, it is on all the subs you can post as far as I can determine. It is also on the startpage.
You might want to change the theme in the forum settings (it has a built in dark theme) and/or disable darkreader for the forum.

Just tried the official sway image 22.06 on my PBPRO and the issue seems to be no longer existent. I checked default packages installed and found that polkit-gnome (and as a dependency polkit) is part of the installed packages (its in the package list since the very beginnings… Blame · editions/sway · master · manjaro-arm / applications / arm-profiles · GitLab). So maybe there was an issue with the package dependencies for polkit-gnome, or something went wrong with the image build…

Can you pls. give it another try?

1 Like