Swapping Kernels?

I have managed to install the new kernel however after a few reboots the system is still using the old one, and there is no option to remove the old one either (doing so I thought might “trigger” the system to use the new one, but that is moot as I cannot uninstall the old one anyway).

How does one change to the newer kernel?

CLI reort

why do you have installed ‘rt’ kernels? do you need them for specific purpose?

if you install newer kernel, you should automatically boot with it… if not, you can tap esc during boot, and the grub menu should appear, and in there in advanced options you select the kernel you want, but dont select the fallback one … or you can do this:
sudo nano /etc/default/grub
and edit this line:
to look like this:
then press ctrl+x to save the file
run this command:
sudo update-grub
reboot and the grub menu will appear automatically

To complement: GRUB/Tips and tricks - ArchWiki

That’s for preventing you from removing the one you are currently running. Switch to the other kernel first.

I see you are testing kernels. Its a good idea to have two installed in case of a bad upgrade or bugs. Imho a LTS kernel works best as a backup, say 5.15.

1 Like

yes I need the RT fro audio work. I was pressing shift at boot…did not think of ESC will try that.

And yes I was aware I can not remove one without first changing to another :slight_smile: - the issue was actually CHANGING to the other one haha!

EDIT: Nope ESC did not work either!

When trying the sudo update-grub I get this “/etc/default/grub: line 6: grub: command not found”

The text as per the instruction now reads menu instead of hidden, but yeah, I get that error message above.

1 Like

You likely input the wrong command. :face_with_raised_eyebrow:

Nope the command was entered correctly - the Line 6 it refers to was already in the grub file!

A good command is sudo nano /etc/default/grub without “line 6”. Edit line 6 then Ctrl+x and then y to save…

When is the error message “/etc/default/grub: line 6: grub: command not found” displayed, when you boot up?

What is line 6 of /etc/default/grub ?

Recent kernels should not need RT anymore, only threadirqs kernel command line required. Of course your actual needs might be tougher that you actually need a RT kernel, just trying to give a suggestion. Ardour and Guitarix run responsively with ~2ms latency on my system.

1 Like

Sorry, just realized in my post above there was a typo: the command I MEANT was sudo update-grub not edit-grub (I changed it)

So this is what I entered and the result:
sudo update-grub
/etc/default/grub: line 6: grub: command not found

What is line 6 of /etc/default/grub ?

yes I thought I should post that:

GRUB_CMDLINE_LINUX="cpufreq.default_governor=performance threadirqs"Generating grub configuration file …

I’m guess that it should only read what is within the quote marks

GRUB_CMDLINE_LINUX="cpufreq.default_governor=performance threadirqs"

for reference mine is just empty quotes


FWIW, this is the complete readout:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor udev.log_priority=3”
GRUB_CMDLINE_LINUX="cpufreq.default_governor=performance threadirqs"Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.19-rt-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.19-rt-x86_64.img
Found initrd fallback image: /boot/initramfs-5.19-rt-x86_64-fallback.img
fgrep: warning: fgrep is obsolescent; using grep -F
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin

it looks like /etc/default/grub has got mixed up some output messages from the terminal.

Could you have pressed the middle mouse button and pasted output from the terminal in there?

Do you have a backup for that file before editing?

here is mine:

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=1234 udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki: https://wiki.archlinux.org/index.php/Fsck#Boot_time_checking

Generating grub configuration file … and the lines after GRUB_DISABLE_OS_PROBER=false don’t like like they belong in a grub config file.

1 Like

Yeah they did seem a bit incongruous but it was all a default Manjaro Install…this is the first time I’ve even looked at the grub, let alone edited it!!

Perhaps this is solved now?

If not:

this would be o.k.
… with nothing else on the same line - just this:
GRUB_CMDLINE_LINUX="cpufreq.default_governor=performance threadirqs"

In fact:
all these parameters should go to:

so that the final result looks like this:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor udev.log_priority=3 cpufreq.default_governor=performance threadirqs”

(with GRUB_CMDLINE_LINUX= being still empty
but all the parameters being in:

1 Like

Thank you, I will give that a try…

EDIT: Nope that doesn’t work either…Unless it is not the ESC key to press?? If it is, then none of the solutions offered enable me to choose the Kernel.

Don’t forget to sudo update-grub after modifying /etc/default/grub.

1 Like