Swap caps and scape in vs code

I have swapped caps and escape in my configuration and it works fine in every program except in vs code. I’m using the vim extension in vs code and I have to press escape twice to return to normal mode.

This is what I’ve used to swap caps and escape:

dconf write /org/gnome/libgnomekbd/keyboard/options "['caps\tcaps:swapescape']"