Suspending Manjaro deepin leads to an abrupt shutdown

Hi everybody. my name is Clawd and i am new here. i have been using Manjaro Deepin as a second OS aside of my Windows 10 and i really like it. The design and interface…It is so nice. I have only one issue: my systems forces my laptop to shutdown when i click the sleep button. It has occured many times now so i dont like to put the computer to sleep, i rather shut it down. My concern is , is it a bug or it is because of a wrong setting on my side? Thanks for your help

Is it shutting down cleanly ? If it takes some time, shows a nice logo during shutdown it’s probably a bug. If it goes black instantly, i’d bet on crashing.

We need your hardware specs, follow this topic

Here are a few things I would check out:

Does systemctl suspend from the terminal suspend properly?

In the Control Center, under Power Management, is “Suspend on lid close” turned on? If so, does closing the lid suspend properly?

What happens when you try to reopen from suspend?

My suspend works properly (99% of the time!), and it only takes a second or two. To do it, I click on the battery icon, then the suspend option. My settings require a password when waking from suspend. Once I enter my password, the screen reappears just as I left it.

A shutdown, on the other hand, requires me to select to boot into Manjaro before asking for my password. Once it opens I have a clean screen.

I do not dual boot, so I wonder if dual booting with Windows affects the laptop’s behavior.

Hi, systemctl suspend works properly, i ve tested it three times. When i close the lid the computer will not suspend, the action set is do nothing. When it has suspended normally without any issue, when i reopen i do not have any problem. As suggested i will shortly send an output of my hardware specs. Writing from windows haha!

Hi. this is my system specs

           Desktop: Gnome  (Gtk 3.22.26+161+g60750b3ffd-1)
           Distro: Manjaro Linux
Machine:   Device: laptop System: Dell product: Inspiron 5567 serial: N/A
           Mobo: Dell model: 01W6F7 v: A00 serial: N/A
           UEFI: Dell v: 1.0.0 date: 07/14/2016
Battery    BAT0: charge: 7.0 Wh 25.8% condition: 27.3/42.0 Wh (65%)
           model: Samsung SDI DELL C4HCW69 status: Discharging
CPU:       Dual core Intel Core i5-7200U (-MT-MCP-)
           arch: Kaby Lake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10852
           clock speeds: max: 3100 MHz 1: 1224 MHz 2: 897 MHz 3: 896 MHz
           4: 890 MHz
Graphics:  Card: Intel HD Graphics 620 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: intel (unloaded: modesetting)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           version: 4.5 Mesa 17.3.3 Direct Render: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.9.79-1-MANJARO
Network:   Card-1: Intel Wireless 3165 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (79.4% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB
Partition: ID-1: / size: 20G used: 11G (57%) fs: ext4 dev: /dev/sda8
           ID-2: /home size: 17G used: 1.5G (10%) fs: ext4 dev: /dev/sda9
           ID-3: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda10
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 173 Uptime: 2 min Memory: 699.3/7886.1MB
           Init: systemd Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121) inxi: 2.3.56 ```
System:    Host: clawd-pc Kernel: 4.9.79-1-MANJARO x86_64 bits: 64 gcc: 7.2.1
           Desktop: Gnome  (Gtk 3.22.26+161+g60750b3ffd-1)
           Distro: Manjaro Linux
Machine:   Device: laptop System: Dell product: Inspiron 5567 serial: N/A
           Mobo: Dell model: 01W6F7 v: A00 serial: N/A
           UEFI: Dell v: 1.0.0 date: 07/14/2016
Battery    BAT0: charge: 7.0 Wh 25.8% condition: 27.3/42.0 Wh (65%)
           model: Samsung SDI DELL C4HCW69 status: Discharging
CPU:       Dual core Intel Core i5-7200U (-MT-MCP-)
           arch: Kaby Lake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10852
           clock speeds: max: 3100 MHz 1: 1224 MHz 2: 897 MHz 3: 896 MHz
           4: 890 MHz
Graphics:  Card: Intel HD Graphics 620 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: intel (unloaded: modesetting)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           version: 4.5 Mesa 17.3.3 Direct Render: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.9.79-1-MANJARO
Network:   Card-1: Intel Wireless 3165 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (79.4% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB
Partition: ID-1: / size: 20G used: 11G (57%) fs: ext4 dev: /dev/sda8
           ID-2: /home size: 17G used: 1.5G (10%) fs: ext4 dev: /dev/sda9
           ID-3: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda10
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 173 Uptime: 2 min Memory: 699.3/7886.1MB
           Init: systemd Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121) inxi: 2.3.56

The shutdown is not clean. It is like when you force shuts with power button pressed for 4 sec. I have that issue when i plugged headphones in the computer, after some researches i discovered that it was a power saving issue. So i edited TLP power settings. I could not do the same thing for the suspend issue.

As a workaround, you might try using the Control Panel / Shortcut section to create a shortcut to systemctl suspend.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.