Suspend/Resume, without password odd behaviour

I have a laptop, xfce on the testing branch and almost always use suspend/resume without locking the screen. It’s only used for browsing and nothing sensitive, so this suits us. Its set up so that closing the lid suspends. (Not hibernate or mixed mode, just suspend to RAM).

If I use the power menu to suspend, then on resume it goes straight to the desktop, no password needed, but if I close the lid it also suspends, but on resume password is needed to login.

I have another laptop that I prefer to require password on resume, but just to test I set this one up also not to lock the screen…

ie. in xfce power manager, ‘Automatically lock the session’ = NEVER and ‘Lock the screen when system is going to sleep’ Un-ticked.

…and now it is also the same behaviour, close the lid and password needed, use the power menu to suspend and password not required.

Why different when resuming, and can I setup so that no password needed in both cases?

Which actions did you configure in Power Management > General > Laptop Lid ?

Thanks for replying.

Laptop Lid is to ‘Suspend’ for both ‘On Battery’ and ‘Plugged in’. Also in that tab, ‘When the sleep button is pressed’ is ‘Suspend’.

I just found this, it might explain.

Thanks, I executed that command, rebooted just in case, and the behaviour is the same as before.

The laptop is Suspending to RAM on lid closure, I get the same indication for both lid close and power button suspend. Also on resume, the laptop is on immediately, just in one case straight to the desktop, and the other with the login screen.

Just to add, seems to me that the ‘lock session’ or ‘Lock screen when going to sleep’, setting is ignored on lid close

Hmm same thing happens to me on manjaro cinnamon, it’s not any inconvenience or anything but thought it was just my laptop being wierd

Interesting, I just moved the laptop to xfce, before was on KDE and the behaviour there was as expected, suspend on lid close respected the settings to either lock or not.

I’ve managed to resolve this now.

I thought it might not have been an xfce4 power manager issue so I disabled it to eliminate it from further troubleshooting. The screen lock still got enabled when suspending by lid, so that led me to thinking there must be another setting somewhere else, but where?

I’ve used the dconf editor before on Ununtu to find obscure settings, but not with Manjaro, so I installed it and did a search for ‘lock’, and there it was a setting called ‘lock-on-lid’ and set to ‘True’. I changed this to ‘False’ and voila, resume after suspend by lid now goes straight to desktop, as it does with suspend by button or by inactivity.

Hopefully someone else may find this solution useful.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.