Suspend/Resume stopped working on my Dell 7375 2-in-1

Hi all,
Here's the deal, suspend has stopped working on my laptop. It used to work fine. Not sure why it quit working (kernel update, maybe?). What happens is, when I close the lid or suspend in any other way, the screen will go black but I can tell by listening that it did not suspend. At this point it has crashed and will not respond to any type of input.

Update: I am pretty sure this is a KDE issue.

Here is my inxi output:

System:    Host: daniel-pc Kernel: 5.2.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           Desktop: KDE Plasma 5.17.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 7375 v: 1.2.0 serial: <filter> 
           Mobo: Dell model: 0GTNWX v: A00 serial: <filter> UEFI: Dell v: 1.2.0 
           date: 02/09/2018 
Battery:   ID-1: BAT0 charge: 39.1 Wh condition: 39.1/42.0 Wh (93%) 
           model: Samsung SDI DELL CYMGM7C status: Full 
CPU:       Topology: Quad Core model: AMD Ryzen 7 2700U with Radeon Vega Mobile Gfx bits: 64 
           type: MT MCP arch: Zen L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
           bogomips: 35149 
           Speed: 1370 MHz min/max: 1600/2200 MHz Core speeds (MHz): 1: 1372 2: 1410 3: 1397 
           4: 1411 5: 1371 6: 1373 7: 1371 8: 1368 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
           vendor: Dell driver: amdgpu v: kernel bus ID: 02:00.0 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.21-1-MANJARO LLVM 9.0.0) 
           v: 4.5 Mesa 19.2.2 direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Dell 
           driver: snd_hda_intel v: kernel bus ID: 02:00.1 
           Device-2: AMD Family 17h HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 02:00.6 
           Sound Server: ALSA v: k5.2.21-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel bus ID: 01:00.0 
           IF: wlp1s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Touchscreen type: USB driver: btusb bus ID: 3-2.1:4 
Drives:    Local Storage: total: 238.47 GiB used: 27.21 GiB (11.4%) 
           ID-1: /dev/sda vendor: Micron model: 1100 SATA 256GB size: 238.47 GiB 
Partition: ID-1: / size: 221.05 GiB used: 27.21 GiB (12.3%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 12.58 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 53.1 C mobo: 41.0 C sodimm: 32.0 C gpu: amdgpu 
           temp: 53 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 218 Uptime: 1h 03m Memory: 11.43 GiB used: 1.42 GiB (12.5%) 
           Init: systemd Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 inxi: 3.0.36 

and journalctl -b -g suspend

-- Logs begin at Wed 2019-10-30 15:58:30 CDT, end at Mon 2019-11-04 16:12:06 CST. --
Nov 04 15:27:16 daniel-pc kdeinit5[1162]: kscreen.kded: PowerDevil SuspendSession action not available!
Nov 04 15:27:17 daniel-pc plasmashell[1219]: org.kde.plasma: invalid metadata "/usr/lib/qt/plugins/" 

Well... Installed Manjaro-Gnome and suspend now works. Will see what happens as time goes by. Not a big Gnome fan but I'll use it for a while.

If you would like to test KDE again try disabling KDE's compositor before suspending. The KDE compositor has been found to be preventing proper suspend on some help threads recently.

Also test different kernels with KDE as the kernel can also in combination with other things cause this type of issue. Your inxi has kernel 5.2 listed. I would test more recent kernels, as well as the LTS kernels 4.19 and 4.14.

I did read that suggestion about disabling compositor and tried it, no luck. I also tried different kernels, as well. When i originally installed Manjaro KDE suspend worked fine. I believe it was 4.19 kernel. Just not sure what caused the issue in the first place.

I'll try reinstalling KDE again after I do a BIOS update (which means installing Win 10... ick). Thanks for the response.

same problem here, but using kde

I installed the latest Manjaro KDE. Very unstable and unusable. Reinstalled Manjaro Gnome and upgraded to latest. Also unstable. Don't know what has happened here but I'm done. Going to download the Win 10 recovery image from Dell for now. Maybe buy a more Linux friendly laptop.

I fixed the suspen resume problem.
first I added a new kernel parameter on witch is: iommu = soft witch will make kde stop crashing the compositor

the second and most important is to start using wayland instead of xorg

hope it helps

Any improvement after the update?

Fixed for me after ugrading on 2019-01-16

Thank you for your response and advice concerning my issues with this laptop. It is very much appreciated. I have to say that this is the most Linux unfriendly laptop I have ever owned. Has not been a smooth ride from day one. Very buggy.

At the moment I have gone back to Windows 10. I did a factory recovery a couple of weeks ago. I haven't given up on Manjaro or KDE. When I get my new and larger SSD installed, I am going to install the latest snapshot of Manjaro to see how that goes.

I am going to consider this issue closed for now. Peace.

Suspension broken again :frowning:

fixed by following kernel parameters on wiki arch

i had to remove many parameters

Thanks for checking up. When I finally did a fresh install Manjaro KDE 19.x, everything was good again. I am running the 4.19 LTS kernel. Seems to work best for me. I am happy, happy, happy. :smiley:

I will try those parameters out and see if they work with a newer kernel. Thanks again.

Forum kindly sponsored by