[Support/How-To] Compile old/legacy Nvidia Proprietary Drivers [2020-12-30 Update Issue]

Think the main bug with the 455 drivers was prime synchronisation but that’s supposed to be fixed in the 460 drivers. Aren’t 460 in unstable branch at the moment?

Yep.

nvidia-utils
repository : extra

Stable : 455.45.01-2
Testing : 455.45.01-2
Unstable : 460.32.03-1

1 Like

The 460 already have the bug of the kernel crash (450 too and confirmed in the post linked on the nvidia forum). I want the 455 drivers, really, but when your computer freeze all days it’s unusable.

Nvidia works on the fix (probably in few weeks/months and the cause is not sure already) so I will switch with pleasure after this fix.

1 Like

yes, that’s the problem for me too. my card is too new to use 390; it only gained support with 440.

repost to make the link:

1 Like

Yep. Not Manjaro’s finest day. It trashed my system and I ended up doing a complete rebuild as I couldn’t find any help in the forums.

“Read: 19 minutes recently”

Maybe you should have tried harder then to ‘find any help on the forum’ I’m pretty sure you could have got some in the update announcement thread to redirect you to the various already opened threads about the ‘Nvidia panic’, or this thread here with all explanations to switch drivers.
It is weird it “trashed your system” as you have a fairly recent video card and it should have been transitioning you to your current drivers version to the latest drivers silently. Maybe you did something wrong in the update process? You may have rejected all the transition it asked to replace all older MHWD packages to the new ones?

I think that is some issue, because my Nividia card is Geforce GT 650M, and it don’t have support to 455 driver.

I had installed before and Noveau was loading instead. The 455 driver even wasn’t listed on Manjaro Settings.

I checked on Nvidia website’s too. The last driver is 418.

yes i may be using a different os (endeavour) but i have problem installing the drier from here
when i install it it tells me that i,m using a manjaro kernel while i,m using zen kernel and headers.
so it tells me it,s unable to install the driver to the kernel and after restart pc the driver work but the pc freezes after opening an app

so now i,m stuck with the noveau that is slow and crashes some apps

this is how to terminal was like (the log from terminal)(installed nvidia utils from pamac (pacman gui) because the makepkg didn,t work well)

[alakondray@alakondray-s-laptop ~]$ cd ../nvidia-340xx-dkms && makepkg -si
bash: cd: ../nvidia-340xx-dkms: No such file or directory
[alakondray@alakondray-s-laptop ~]$ cd ./nvidia-340xx-dkms && makepkg -si
==> WARNING: The package group has already been built, installing existing packages...
==> Installing nvidia-340xx package group with pacman -U...
[sudo] password for alakondray: 
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) nvidia-340xx-dkms-340.108-1

Total Installed Size:  14.64 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                   [----------------------------------------------] 100%
(1/1) checking package integrity                                                 [----------------------------------------------] 100%
(1/1) loading package files                                                      [----------------------------------------------] 100%
(1/1) checking for file conflicts                                                [----------------------------------------------] 100%
(1/1) checking available disk space                                              [----------------------------------------------] 100%
:: Processing package changes...
(1/1) installing nvidia-340xx-dkms                                               [----------------------------------------------] 100%
Optional dependencies for nvidia-340xx-dkms
    linux-headers: Build the module for Manjaro kernel [installed]
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Install DKMS modules
==> dkms install --no-depmod -m nvidia -v 340.108 -k 5.10.5-zen1-1-zen
==> dkms install --no-depmod -m nvidia -v 340.108 -k 5.10.5-arch1-1
==> depmod 5.10.5-zen1-1-zen
==> depmod 5.10.5-arch1-1
==> Unable to install module nvidia/340.108 for kernel 5.9.14-zen1-1-zen: Missing kernel headers.
==> Unable to install module nvidia/340.108 for kernel 5.9.14-arch1-1: Missing kernel headers.
[alakondray@alakondray-s-laptop nvidia-340xx-dkms]$

418 drivers work only with kernel 5.4? With other kernels it is not worth trying?