Super + Space cannot be used with Fcitx in GTK4 apps

Super + Space is the default IME switch shortcut in Gnome, if you use IBus, I think. To use that shortcut with Fcitx, an alternative to IBus, you need to remove that Super + Space in the keyboard shortcut section of Gnome Settings. Then, Super + Space works with Fcitx, except in GTK4 applications.

At first, I thought that this is a bug of GTK or Gnome, but when I tried Endeavour OS or Fedora, Super + Space worked in GTK4 apps. Their Gnome versions were also 43.2, just like that of Manjaro, so I am not sure if this is Gnome’s bug. This problem happens on two independent Manjaro installations on my computers. Maybe it problem is due to Manjaro’s customisations?

I have tested it some more and it happens with a fresh install of the latest Gnome Manjaro (for both full and minimal: manjaro-gnome-22.0-221224-linux61.iso manjaro-gnome-22.0-minimal-221224-linux61.iso). At first, it did not seem to happen, but that was because X11 was the default. It does not happen in X11, but only with Wayland.

Steps to reproduce:

  1. Install Gnome Manjaro
  2. Open Settings → Keyboard → Keyboard Shortcuts → Typing, remove Super + Space.
  3. Install Fcitx5, configtool, Mozc, etc.
  4. Reboot
  5. In Fcitx5 configtool,
    1. Add some languages like Mozc.
    2. clear existing shortcuts and add Super + Space for the activation shortcut.
  6. Open Files, click the magnifier icon, and press Super +Space. Fcitx5 works.
  7. Change false to true for the value of WaylandEnable in /etc/gdm/custom.conf .
  8. Re-log into Wayland and repeat step 6. Fcitx5 does not work.