Super key does not show Activities menu in Gnome 3.36

Hello everyone,

After upgrading to Gnome 3.36 (I followed the instructions to upgrade from a tty) my Super key does not show the activities menu anymore.
If I drag the mouse to the upper left corner the menu opens, as expected.

I know that the Super key is not locked and working because if I use the Super + A shortcut, it takes me to the Applications menu.

I tried setting the Super key to the activities using the settings but it's not possible because Super is a mod key.
Using Gnome Tweaks I've set the left super to open the activities, but it's not working.

Does anyone have a similar problem?
Any toughts on the solution?

Thanks.

1 Like

Yes, here


see my comment on that one
and something related here, with some more detail but not sure how it ended of the OP

On my install i can't reproduce the issue.

Well, it seems like the second post you linked has the same problem I have.

If I set the input to #1 then the Super key works as it should.
The problem is with the #2.

I think I should wait for the bugfix.

Thanks!

Correct upstream issue is https://gitlab.gnome.org/GNOME/mutter/-/issues/1144
Please upvote it. Hopefully they'll look into it soon.

I confirm the problem. Russian language.

This issue is not hard to reproduce at all. Some keyboards that have the problem:

  • Portuguese (Brazil, Dvorak)
  • English (Dvorak, international, with dead keys)
  • Russian

Some keyboards that DO NOT have the issue:

  • English (US, international, with dead keys)
  • Polish

I am a Gnome Shell user and this issue makes my desktop unusable!

EDIT: Workaround: This behaviour doesn't depend on the language itself, but on its position in the Input Sources list. #1 works, #2 and 3 don't, #4 works again.

It works with such settings for me. Suitable as a temporary solution.

dconf-editor > /org/gnome/desktop/wm/keybindings/panel-main-menu > ['Super_L']

Unfortunately proposed workaround doesn't work for me: it conflicts with default keyboard layouts switching shortcut (super + space). When trying to change input language from layout 2 to layout 1 it brings up overview in the middle of the process.

I change the layout of Alt-Shift. :man_shrugging:

Forum kindly sponsored by