Suggestions to improve Manjaro Deepin

deepin
#1

In this post i would like to address some of my issues with Manjaro Deepin edition . Feel free to correct me if this was already implemented

1 Remove uninstall option from Deepin menu. As far as I am aware uninstalling from the menu doesn’t work because of Deepin store. This store is exclusive to Deepin OS. So uninstall option is useless on Manjaro.
DeepinScreenshot20170422000400

2 If possible integrate Manjaro settings in control center like it was already integrated on other community editions

3 When you press power button in deepin os , this menu appears( refered as dde-shutdown). However in Manjaro Deepin system just powers off instantly. There is no option to change that behavior.

1 Like

#2
  1. control center > keyboard and Language > Keyboard Layout > Add Keyboard Layout

no work at all for any language

apart that Deepin is N1.

oh indicator of weather is that would be the icing on the cake to conclude :heart_eyes:

0 Likes

#3
  1. I believe this works now as just removing .desktop for programs, but leaving program itself is active…Sometimes rarely it can even be useful, but in general i guess it could be removed

  2. Would be nice, but i doubt it will be implemented in near future, since Deepin settings are very different from other ones + there’s too many bugs and development on Deepin side now is very active

  3. Yep, i confirm it, but it’s default Manjaro reaction as far as i know, maybe could be tweaked with dconf, i’ve found power-button-pressed-exec=‘dde-shutdown’ there

Actually it did, before yesterday update:

1 Like

#4

Tnx for feedback

0 Likes

#5

For those who still interested in this questions:

Already here with today’s updates, no uninstall for Arch / Manjaro)

This and some related bugs are in the process of fixing, some already fixed for Arch, but not in Manjaro yet.

1 Like

#6

Awesome!

0 Likes

#7

@rydhwan

Can you please check, if you have same errors running sudo journalctl -p 3 -xb:

feb 09 23:49:37 x133-pc daemon/dde-system-daemon[923]: main.go:89: failed to request name: name com.deepin.daemon.Daemon already taken
                                                            ->  proc.go:201
                                                            ->  asm_amd64.s:1333
feb 09 23:49:37 x133-pc daemon/dde-system-daemon[942]: main.go:67: name "com.deepin.daemon.Daemon" already has the owner
                                                            ->  proc.go:201
                                                            ->  asm_amd64.s:1333
feb 09 23:49:37 x133-pc daemon/dde-system-daemon[948]: main.go:67: name "com.deepin.daemon.Daemon" already has the owner
                                                            ->  proc.go:201
                                                            ->  asm_amd64.s:1333
feb 09 23:49:37 x133-pc daemon/dde-system-daemon[959]: main.go:67: name "com.deepin.daemon.Daemon" already has the owner
                                                            ->  proc.go:201
                                                            ->  asm_amd64.s:1333

And tell if you have autologin enabled?
That would help debug

0 Likes

#8

Works now with 23.02.2019 Manjaro Deepin update.

Now autologin, keyboard layouts, keyborad switch, system language switch works good, with 23.02.2019 Manjaro Deepin update.

This was a complex problem of deepin-daemon, which lead to a lot of bugs.

Together with brilliant & fast programmers from Deepin & @oberon from Manjaro we worked hard to fix, debug and test this issue.

Now even if you had this errors and autologin enabled, after update shouldn’t have any problems.
I’ve tested it on couple of VMs and real test-machine, in terms of this problem everything is good.

But still, if someone will notice anything about it - please let me know, or report to Deepin upstream.

For those who interested in this messy process:

1 Like

closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes