[Suggestion] Set AutoEnable=true in /etc/bluetooth/main.conf

Hi,

today the most desktop and notebook users are using bluetooth input devices. But after pairing and restart a bluetooth mouse or keyboard isn't usable by default within the login screen. To use these devices it's necessary to set AutoEnable=true in /etc/bluetooth/main.conf.

So my sugesstion is to set this option out of the box to true.

Kind Regards,
Danny

well not me.
i would want it to be disabled by default.
enable only when needed

8 Likes

That's what udev rules are for. :wink:

1 Like

I would consider that a security issue.
Besides, not everyone has the same tastes.
One of the first things I do on any system is blacklist bluetooth and anything related to it.
But, as you pointed out, it is easily configurable to your taste if you want autoenable.

2 Likes

I use bluetooth occasionally but certainly do not want it auto-starting. It is a security risk but also a waste of power having radio that is not being used enabled all the time. I have stopped KDE from doing that on my notebook. It even turned it back on at one point when the battery was critically low. I don't know why they'd stipulate that in the powerdevil default scheme but I changed it as soon as I noticed.

Ha ha, same here. :smile:

1 Like

I'll raise y'all one...I don't have any radio-related capability.

2 Likes

Forum kindly sponsored by