Sudo rc-update add pulseaudio default * rc-update: service `pulseaudio' does not exist


#1

just installed xfce openrc on my last working machine which is only two months old so i am sure it isn’t hardware issues

needless to say, pulse audio is installed…


#2

Pulseaudio doesn’t need to be added as a service. See here:


#3

Tried that before posting my post above. No dice


#4

Try adding alsasound to runlevel default ;

sudo rc-update add alsasound default

If the service not exist, Try installing alsa-utils-openrc :

sudo pacman -Sy alsa-utils-openrc

#5

You could also try pulseaudio --start in a terminal to see if it works. (Then add it as a startup script, if desired; my XFCE install has that, but I don’t use it, I only start PA when I want it.)


#6

pulseaudio --start
E: [pulseaudio] main.c: Daemon startup failed.


#7


#8

start-pulseaudio-x11
Connection failure: Connection refused
pa_context_connect() failed: Connection refused


#9

i do get sound in another os…

inxi -Fxzc0
System:    Host: manjaroed Kernel: 4.9.38-1-MANJARO x86_64 (64 bit gcc: 7.1.1) Desktop: N/A
           Distro: Manjaro Linux
Machine:   Device: laptop Mobo: GIGABYTE model: M1M3XCP-00 v: 1.x BIOS: American Megatrends v: F3 date: 10/30/2015
CPU:       Quad core AMD A8-5557M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 16775
           clock speeds: max: 2100 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Richland [Radeon HD 8550G] bus-ID: 00:01.0
           Display Server: x11 (X.Org 1.19.3) driver: modesetting Resolution: 1600x900@60.00hz
           OpenGL: renderer: Gallium 0.4 on AMD ARUBA (DRM 2.49.0 / 4.9.38-1-MANJARO, LLVM 4.0.1)
           version: 4.1 Mesa 17.1.5 Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.9.38-1-MANJARO
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: e000 bus-ID: 05:00.0
           IF: enp5s0 state: down mac: <filter>
           Card-2: Intel Wireless 3160 driver: iwlwifi bus-ID: 06:00.0
           IF: wlp6s0 state: up mac: <filter>
Drives:    HDD Total Size: 604.3GB (3.6% used)
           ID-1: /dev/sda model: SanDisk_SDSSDA48 size: 480.1GB
           ID-2: USB /dev/sdb model: Ultra_Fit size: 124.2GB
Partition: ID-1: / size: 15G used: 4.0G (30%) fs: btrfs dev: /dev/sdb4
           ID-2: /home size: 25G used: 1.1G (5%) fs: btrfs dev: /dev/sdb5
           ID-3: /boot size: 240M used: 41M (18%) fs: ext3 dev: /dev/sdb3
           ID-4: swap-1 size: 17.17GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A gpu: 53.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 210 Uptime: 8 min Memory: 868.1/11207.7MB
           Init: SysVinit rc: OpenRC runlevel: default Gcc sys: 7.1.1 Client: Shell (bash 4.4.121) inxi: 2.3.23

#10

@LizziAS , (Assumed that you were using XFCE) Try to go to Settings > Session and Startup > Application Autostart tab, then check or add both Pulse audio Applet ( pa-applet) and Pulse Audio Sound System (start-pulseaudio-x11). And thne, reboot after it

Hope this works!


#11

it was checked already


#12

If so, did you see the pulseaudio icon in the taskbar when reboot or you did see it, but the audio it’s still not working?


#13

Pavu control reports the same error as above in the photo::


#14

Try resetting pulse audio settings :

rm -rf /tmp/pulse* ~/.pulse* ~/.config/pulse
pulseaudio -k
pulseaudio --start

Is it another manjaro OS or windows? If manjaro (with working audio), try to compare packages between two distro to see any packages that went missing

pacman -Qs pulse
pacman -Qs audio

#15

Wait did it actually work? Please reply, don’t leave me hangin’ :((((


#16

Well that is the correct solution though. I installed openrc on top of a systemd system and i did reformat my root directory but not my home directory so i thin your solution is correct.

However, i got frustrated with it and reinstalled and started over with installing pulse audio and now it works. but you desrve credit for a right response.


#17

so what i finally did on a reinstall i found the same problem again.

so i uninstalled pulseaudio files and then reinstalled them and while i was reinstalling them i had pavucontrol open and i saw pulse audio come up straight away after reinstalling the pulseaudio files…

quirky but it worked…


closed #18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.