Sudo password won't be accepted

Hi, I have used Manjaro already for a number of years, but recent problems (on which I worked several weeks without success) forced me to try a new installation. Everything went smoothly. This time I thought I’m smart and install it with a different password for root. Thus I have two passwords, one for me as regular user and one for root.
Now I want to install software which I used to use and want to continue to use. I used for that purpose pacman, entered “sudo pacman -S [packagename]” and was prompted for the password. I entered my password and got the response that it wasn’t accepted. I tried it three times with no luck. I used faillock to reset the lock-count, but it still didn’t work.
I tried su, and the root-password was accepted. I got into the system with my regular password, the same I used for sudo. I wonder what could cause such strange behaviour?

visudo -sc

reports back that /etc/sudoers and /etc/sudoers.d/10-installer are both ok, but /etc/sudoers.d/ctdb has wrong access rights, should be 0440. I checked with “ls -l”, it shows 0600 access rights. So I changed the access rights to 440, and now “visudo -sc” returns for all three “ok” status. But it still doesn’t work (before testing, I made sure that faillock didn’t show any lock status for me).

Try resetting the password for regular user:

su #enter root password
passwd <user_name> #enter new password for the user

That one allowes users of wheel group to use sudo.
Is your user a member of wheel group?

$ groups

Thank you for you quick responses. I just did a restart (should have done that before I posted here) and it seems to work now. Still strange, but I’m glad it works now (and I hope it stays that way). And yes, I am member of wheel group.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.