Stuck with a blinking cursor

Hi.
I'm having an issue with the official Manjaro installer (Gnome).
I was trying to install it on my system, I've created the USB installation drive using Rufus.
It booted up, but after a few seconds, the installation froze.
Here is a video that shows the issue:

My specs are
-MSI x399 gaming pro carbon
-AMD Treadripper 1950x
-Nvidia Geforce RTX 2060 super
-32 GB of DDR4 ram

I'm quite sure that the USB drive is working. I tried to use it with another PC, and it worked fine on it.
I'm not the first who has this problem, but none of the other threads helped me.
Do you have any suggestion?

P.S.
I'm quite new to Linux, and my English is not the best, since it's not my main language. So please, forgive my inaccuracy.

Use Rufus in DD mode only.

First adopters always suffer - I am not aware which generation your hardware is - it looks quite new to me :slight_smile: .

Using the latest version of Rufus, it's no longer possible to select the DD mode. I've tried with a previous version too, making sure I was using DD, but unfortunately it didn't fix the problem.

Yes, my gpu is from the latest Nvidia series.
The cpu, on the other hand, is from the first Ryzen series.

The developer of Rufus is using an ISO pattern recognition to automatically use dd mode when a Manjaro ISO is detected.

Search the forum for rufus to find the actual post.

1 Like

Great! :smiley:
I already heard about that, but I wasn't 100% sure.

The Manjaro ISO's typically ship with the latest LTS kernel (at this time 4.19.x series).
The RTX 2060 like the RTX 2070 require a 5.x series kernel to use the built in nouveau drivers.
With the non-free drivers, a minimum of the 430.34 version of driver is required.

What version of the Manjaro ISO are you using?
(desktop type and release version number)

2 Likes

If I use the free drivers, my screen starts glitching. In fact, I used the non-free drivers in the video.
The version I'm using is the full 64 bit Manjaro, with Gnome, downloaded here:


(18.1.3)

Gnome defaults to wayland, but even at that, gdm/gnome implements the non-standard, Nvidia eglstreams, in it's own code. I'm not sure if Manjaro gnome has this though or not.

you need a recent version driver nvidia 440xx series
maybe see a more recent dev iso

If it can help, Ubuntu worked when I tried it a while ago. If I remember correctly, it uses Gnome too, I'm not sure it's the same version though. What do you suggest me to do?

As I already mentioned in a previous post.
Support for the RTX 2060 super was added in the 430.34 version of nvidia driver:
https://www.geforce.com/drivers/results/148589

other iso

Thank you. I'm trying now

Same behaviour, exactly like the full version :pensive:

I've a pretty weird update. Waiting some minutes, my PC was automatically suspended.
When woken up again, the OS works, but it's definitely glitching. Some animations are very laggy and there is a lot of screen tearing, but it's absolutely usable.
Now that it's unexpectedly working, should I try to do something in particular to make the USB live environment work, without this strange workaround?

Nothing you can do, the ISO is read only for one thing, and it loads compressed file systems one on top of each other to boot into a live, install-able system, rootfs, mhwdfs, desktopfs, and finally livefs.

I've tried a few different versions lately:
19.09.28
18.1.4-pre1
19.0-minimal
18.1.3-minimal
18.1.3
No luck with them :pensive:

Hey guys. I've just tried the new 18.1.4 release, which implements the new kernel. But unfortunately I'm still having the same issue:

Forum kindly sponsored by