Stuck while booting XFCE 21.2.1 on AMD Ryzen Laptop

Hello Community,
Glad to join.
I’ve bought a Machenike Mach Creator laptop with AMD Ryzen 4500 processor with AMD Radeon graphics. Windows 10 runs smoothly, I also managed to start Lubuntu. Now I wanted to try Manjaro and had it downloaded onto USB stick. Unfortunately, while booting from it loading Manjaro stalls while diplaying “A start job is running for load Kernel Modules” and the red asterisk that normally runs left to right on that line freezes".
Can you suggest how to overcome that?
Outputs about processor and graphics card:

sudo lshw -C video:
*-display
description: VGA compatible controller
product: Renoir
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:05:00.0
logical name: /dev/fb0
version: c3
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list fb
configuration: depth=32 driver=amdgpu latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
resources: iomemory:fc0-fbf iomemory:fc0-fbf irq:0 memory:fce0000000-fcefffffff memory:fcf0000000-fcf01fffff ioport:1000(size=256) memory:d0400000-d047ffff

lscpu:
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 48 bits physical, 48 bits virtual
CPU(s): 1
On-line CPU(s) list: 0
Thread(s) per core: 1
Core(s) per socket: 1
Socket(s): 1
NUMA node(s): 1
Vendor ID: AuthenticAMD
CPU family: 23
Model: 96
Model name: AMD Ryzen 5 4500U with Radeon Graphics
Stepping: 1
CPU MHz: 2021.550
BogoMIPS: 4740.75
Virtualization: AMD-V
L1d cache: 32 KiB
L1i cache: 32 KiB
L2 cache: 512 KiB
L3 cache: 4 MiB
NUMA node0 CPU(s): 0
Vulnerability Itlb multihit: Not affected
Vulnerability L1tf: Not affected
Vulnerability Mds: Not affected
Vulnerability Meltdown: Not affected
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1: Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2: Mitigation; Full AMD retpoline, IBPB conditional, IBRS_FW, STIBP disabled, RSB filling
Vulnerability Srbds: Not affected
Vulnerability Tsx async abort: Not affected
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_t
sc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf rapl pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand lah
f_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx
cpb cat_l3 cdp_l3 hw_pstate ssbd mba ibrs ibpb stibp vmmcall fsgsbase bmi1 avx2 smep bmi2 cqm rdt_a rdseed adx smap clflushopt clwb sha_ni xsaveopt xsavec x
getbv1 xsaves cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local clzero irperf xsaveerptr rdpru wbnoinvd arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clea
n flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif v_spec_ctrl umip rdpid overflow_recov succor smca

Thanks for any help.

can you tell how you create USB iso ?

I used balena etcher, the other time i used rufus. With same results, unfortunately.

try with ventoy

@stephane: I just did. Both in standad and in compatibility mode, with proprietary or open drivers chosen at boot prompt it gets me into terminal mode displayng:
"Starting version 250-5-manjaro
mount : /run/miso/sfs/livefes: wrong fs type, bad option, bad superblockon /dev/loop0, missing codepage or helper program, or othererror.
ERROR: failed to mount ‘deve/loop0’
Failing back to interactive prompt
You can try to fix this problem manually, log out when you are finished
sh: can’t access tty: job control turned off
[[rootfs]# "
Unfortunately doesn’t boot any forward into graphical interface :thinking:

which iso did you use ?
see if there is new version iso Manjaro - Downloads

I ued the XFCE 21.2.2 - the newest one.

recheck all options in UEFI motherboard

secureBoot off
fast Boot off
no CSM or Legacy
all disks on AHCI ( no raid )
no Optane/RST

All is off.Actually, i had fastboot on . Now I switched it off but get exactly same error messages as above…

Any new information to this issue yet? I just installed an AMD Radeon RX 6600 and have a similar issue. My installed Manjaro xfce semed to fail to start lightdm. Tried a live boot drive and it will not boot without proprietary drivers option, it will boot with proprietary drivers option and then I am able to install. When I try to start the installed version, then my monitor says there is no cable attached and switches off the monitor. Endeavour OS and Fedora are working though, the graphical installer of Debian starts, but shows broken graphics.