Stuck on welcome screen after crash while updating

boot

#1

Hi,

My laptop recently froze up while performing a large update so I shut it down with Alt-SysRq-O. After rebooting it just gets stuck at the loading screen after boot with the Manjaro logo.

I have tried running pacman -Syyuu by using chroot with a USB installation but this hasn’t fixed the problem. If I remove quiet splash in the GRUB menu and try to boot I can see the following error:

: : running early hook [udev]
Warning: /lib/modules/4.1.45-1-MANJARO/modules.devname not found - ignoring
starting version 234
: : running hook [udev]
: : Triggering uevents...
: : running hook [plymouth]
Loading plymouth...done
: : running hook [resume]
ERROR: resume: no device specified for hibernation
Waiting 10 seconds for device /dev/disk/by-uuid/b47d45de-a230-48dd-81dd-3c502e3c9936 ...
ERROR: device 'b47d45de-a230-48dd-81dd-3c502e3c9936' not found. Skipping fsck.
: : mounting 'UUID=b47d45de-a230-48dd-81dd-3c502e3c9936' on real root
mount: /new_root: can't find UUID=b47d45de-a230-48dd-81dd-3c502e3c9936.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off

Is there a way to fix this without a reinstall?


#2

You may use one of our install medias and try to chroot into your installed Manjaro. Then you may try to finish the update you got a crash and try to reboot.


#3

He already tried this, but didn’t work.

@Asraelite This is way over my head, but since I’m already responding, first error is pointing to fstab looks like? (no device specified for hibernation) … could it be that fstab is somehow corrupted?


#4

I don’t think so, I seem to be able to access all my partitions and read from them fine. How would I check if fstab was corrupted?

I tried following the instructions here but using linux41 in the last command instead of linux which returned an error. It now gets past the welcome screen but tty1 only shows

starting version 235
ManjaroRoot: clean, 963530/10477568 files, 37954747/418977728 blocks

and nothing else. My desktop also does not start. I can use tty2 though.


#5

if you did copy-paste from that guide the last command is written incorrectly
the right one is

mkinitcpio

and not

mikinitcpio

#6

You are correct, shouldn’t be fstab, especially since you can access tty now, this is good, this mean system is mostly normal now but probably only some graphic problems persist preventing gui to load.

Was your system longer time without update, since in your first post I see “starting version 234” which is systemd version that is older. Searching internet with your error msg I saw this post when someone had similar error, with arch that was not updated for a while. He solved it by reinstalling the kernel: (post #4. posted today)

https://bbs.archlinux.org/viewtopic.php?id=183567

But otherwise, this is way above my knowledge, I wouldn’t know more than updating through chroot (or tty in your case) and booting with different kernel version. I hope someone else can help you.


#7

Try to boot again from usb anf in main boot choose advanced option and then second one.You should boot into system.After that try to fix what you must


#8

@gionno I figured, I used mkinitcpio in my command.

@AlManja Yeah I think it’s a separate graphics issue now, it boots fine otherwise. I tend to keep my system up-to-date, the update that caused the issue only became available to me yesterday. I don’t now why systemd was an older version but I tried updating to kernel 4.9 and booting with that and I get the same issue.

My graphics card has always caused trouble so I think it might just be a problem with that, possibly unrelated to the boot issues. I’ll search around for solutions to it and if I can’t find any make a new thread. Thanks for the help.


#9

My bad, I messed up numbers, sorry, looks like 234 was current until this big update for stable.


#10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.