Stuck on TUF gaming screen on bootup

This morning I tried to launch OBS and I got the same error as here:

I ran sudo pacman -S nvidia but they were all up to date. I ran sudo pacman -Syyu and it said that my kernel was old and hadn’t been restarted for a while, please restart.

On rebooting it is stuck on the TUF Gaming screen, when I boot on different kernels: 5.10, 5.4, 4.19. Same thing for initfallback-ramfs with 5.10. On 4.14 I got a flashing underscore and then a black screen. I couldn’t switch to the tty on any of them.

After the first boot into 5.10, I did the same thing as above, launch into the liveusb, and update via chroot. But it says that nothing was needed to do. I still updated grub, exited and rebooted.

Just 6 days ago I was having this issue:

But I was able to use OBS Studio, record a video, and upload it to YouTube 4 days ago, so this issue seems to have been caused by doing something else after that.

Hi, i would suggest to update your BIOS as it is from 2019. This may solve some issues.