Stuck on "Reached Target Graphical Interface" after changing my graphics card (from an AMD Radeon RX 560 to a radeon RX 6600)

Title says it all. I have changed from my old RX 560 card to a new RX 6600, which I know is working perfectly well and fine because I have tested it on my Windows 10 dual boot installation on the same machine.

I have used

mhwd -r pci video-linux

to remove the drivers, and then

mhwd -a pci free 0300 systemctl reboot

to install them back and reboot the system but this has not solved the problem

For some reason the forum is not letting me upload a picture but the three final things it says on the boot log thing are
[ OK ] Started Virtualization daemon.
[ OK ] Reached target Multi-User System.
[ OK ] Reached target Graphical Interface.

mhwd -i pci video-linux && systemctl reboot

I have solved, the problem was that I was utilizing kernel 5.10, changing it to a newer version made everything work fine and well

That makes sense. Older kernels don’t support newer hardware.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.