Stuck on loop with blinking cursor after update

Hello hello,

So, I updated my machine today and after a reboot I’m stuck on a loop at boot. What I mean by loop is :

  • Blinking cursor
  • Type Ctrl-Alt-F2
  • See the login prompt for less than a second
  • Instant go back to blinking prompt

I already tried to edit the grub command. I was then able to connect with my user. I tried to update, but nothing to update.

What else could I do?

Thanks :slight_smile:

Increase your chances of solving your issue:

Provide Information:

Here is the output for inxi --admin --verbosity=7 --filter --width

12System: 12Kernel 5.10.42-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 11.1.0 12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro misolabel=MANJARO_XFCE_2107 quiet systemd.show_status=1 apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 12Desktop Xfce 4.16.0 12tk Gtk 3.24.29 12info xfce4-panel 12wm xfwm 4.16.1 12dm N/A 12Distro Manjaro Linux 12base Arch Linux 12Machine: 12Type Laptop 12System Dell 12product XPS 15 9500 12v N/A 12serial <filter> 12Chassis 12type 10 12serial <filter> 12Mobo Dell 12model 05XYW7 12v A00 12serial <filter> 12UEFI Dell 12v 1.7.1 12date 03/29/2021 12Battery: 12ID-1 BAT0 12charge 59.7 Wh (100.0%) 12condition 59.7/84.3 Wh (70.8%) 12volts 12.5 12min 11.4 12model BYD DELL M59JH06 12type Li-poly 12serial <filter> 12status Full 12Memory: 12RAM 12total 15.39 GiB 12used 2.19 GiB (14.2%) 12Array-1 12capacity 64 GiB 12slots 2 12EC None 12max-module-size 32 GiB 12note est. 12Device-1 DIMM A 12size 8 GiB 12speed 12spec 3200 MT/s 12actual 2933 MT/s 12type DDR4 12detail synchronous 12bus-width 64 bits 12total 64 bits 12manufacturer 802C00000000 12part-no 8ATF1G64HZ-3G2J1 12serial <filter> 12Device-2 DIMM B 12size 8 GiB 12speed 12spec 3200 MT/s 12actual 2933 MT/s 12type DDR4 12detail synchronous 12bus-width 64 bits 12total 64 bits 12manufacturer 802C00000000 12part-no 8ATF1G64HZ-3G2J1 12serial <filter> 12CPU: 12Info 12model Intel Core i7-10750H 12bits 64 12type MT MCP 12arch Comet Lake 12family 6 12model-id 0xA5 (165) 12stepping 2 12microcode 0xE2 12Topology 12cpus 1x 12cores 6 12tpc 2 12threads 12 12smt enabled 12cache 12L1 384 KiB 12desc d-6x32 KiB; i-6x32 KiB 12L2 1.5 MiB 12desc 6x256 KiB 12L3 12 MiB 12desc 1x12 MiB 12Speed (MHz) 12avg 1082 12high 3100 12min/max 800/5000 12base/boost 2871/2600 12scaling 12driver intel_pstate 12governor powersave 12volts 0.8 V 12ext-clock 100 MHz 12cores 121 800 122 800 123 800 124 800 125 800 126 800 127 800 128 800 129 1891 1210 3100 1211 800 1212 800 12bogomips 62431 12Flags 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 12Vulnerabilities 12Type itlb_multihit 12status KVM: VMX disabled 12Type l1tf 12status Not affected 12Type mds 12status Not affected 12Type meltdown 12status Not affected 12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via prctl and seccomp 12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization 12Type spectre_v2 12mitigation Enhanced IBRS, IBPB: conditional, RSB filling 12Type srbds 12status Not affected 12Type tsx_async_abort 12status Not affected 12Graphics: 12Device-1 Intel CometLake-H GT2 [UHD Graphics] 12vendor Dell 12driver i915 12v kernel 12bus-ID 00:02.0 12chip-ID 8086:9bc4 12class-ID 0300 12Device-2 NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] 12vendor Dell 12driver nouveau 12v kernel 12bus-ID 01:00.0 12chip-ID 10de:1f95 12class-ID 0302 12Device-3 Realtek Integrated_Webcam_HD 12type USB 12driver uvcvideo 12bus-ID 1-11:3 12chip-ID 0bda:5510 12class-ID fe01 12serial <filter> 12Display 12server X.Org 1.20.11 12compositor xfwm4 12v 4.16.1 12driver 12loaded modesetting 12display-ID :0.0 12screens 1 12Screen-1 0 12s-res 1920x1200 12s-dpi 96 12s-size 508x317mm (20.0x12.5") 12s-diag 599mm (23.6") 12Monitor-1 eDP1 12res 1920x1200 12hz 60 12dpi 143 12size 340x210mm (13.4x8.3") 12diag 400mm (15.7") 12Message Unable to show advanced data. Required tool glxinfo missing. 12Audio: 12Device-1 Intel Comet Lake PCH cAVS 12vendor Dell 12driver snd_hda_intel 12v kernel 12bus-ID 00:1f.3 12chip-ID 8086:06c8 12class-ID 0403 12Sound Server-1 ALSA 12v k5.10.42-1-MANJARO 12running yes 12Sound Server-2 JACK 12v 1.9.19 12running no 12Sound Server-3 PulseAudio 12v 15.0 12running yes 12Sound Server-4 PipeWire 12v 0.3.42 12running no 12Network: 12Device-1 Intel Comet Lake PCH CNVi WiFi 12vendor Rivet Networks 12driver iwlwifi 12v kernel 12bus-ID 00:14.3 12chip-ID 8086:06f0 12class-ID 0280 12IF wlp0s20f3 12state up 12mac <filter> 12IP v4 <filter> 12type dynamic noprefixroute 12scope global 12broadcast <filter> 12IP v6 <filter> 12type dynamic noprefixroute 12scope global 12IP v6 <filter> 12type noprefixroute 12scope link 12WAN IP <filter> 12Bluetooth: 12Device-1 Intel AX201 Bluetooth 12type USB 12driver btusb 12v 0.8 12bus-ID 1-14:4 12chip-ID 8087:0026 12class-ID e001 12Report rfkill 12ID hci0 12rfk-id 1 12state down 12bt-service N/A 12rfk-block 12hardware no 12software yes 12address see --recommends 12Logical: 12Message No logical block device data found. 12RAID: 12Message No RAID data found. 12Drives: 12Local Storage 12total 983.75 GiB 12used 74.09 GiB (7.5%) 12SMART Message Required tool smartctl not installed. Check --recommends 12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor SK Hynix 12model PC611 NVMe 1TB 12size 953.87 GiB 12block-size 12physical 512 B 12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12type SSD 12serial <filter> 12rev 11001111 12temp 32.9 C 12ID-2 /dev/sda 12maj-min 8:0 12type USB 12vendor Samsung 12model Type-C 12size 29.88 GiB 12block-size 12physical 512 B 12logical 512 B 12type N/A 12serial <filter> 12rev 1100 12Message No optical or floppy data found. 12Partition: 12ID-1 / 12raw-size 953.57 GiB 12size 937.53 GiB (98.32%) 12used 74.09 GiB (7.9%) 12fs ext4 12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2 12label N/A 12uuid c9bfad92-f1d5-40ce-8daf-bf160e9886bb 12ID-2 /boot/efi 12raw-size 300 MiB 12size 299.4 MiB (99.80%) 12used 304 KiB (0.1%) 12fs vfat 12block-size 512 B 12dev /dev/nvme0n1p1 12maj-min 259:1 12label NO_LABEL 12uuid 40F9-A619 12Swap: 12Alert No swap data was found. 12Unmounted: 12ID-1 /dev/sda1 12maj-min 8:1 12size 2.42 GiB 12fs N/A 12label MANJARO_XFCE_2107 12uuid 2021-06-14-15-23-05-00 12ID-2 /dev/sda2 12maj-min 8:2 12size 4 MiB 12fs N/A 12label MISO_EFI 12uuid 0545-B0D1 12USB: 12Hub-1 1-0:1 12info Hi-speed hub with single TT 12ports 16 12rev 2.0 12speed 480 Mb/s 12chip-ID 1d6b:0002 12class-ID 0900 12Device-1 1-10:2 12info Shenzhen Goodix FingerPrint 12type <vendor specific> 12driver N/A 12interfaces 1 12rev 2.0 12speed 12 Mb/s 12power 100mA 12chip-ID 27c6:533c 12class-ID ff00 12Device-2 1-11:3 12info Realtek Integrated_Webcam_HD 12type Video 12driver uvcvideo 12interfaces 5 12rev 2.0 12speed 480 Mb/s 12power 500mA 12chip-ID 0bda:5510 12class-ID fe01 12serial <filter> 12Device-3 1-14:4 12info Intel AX201 Bluetooth 12type Bluetooth 12driver btusb 12interfaces 2 12rev 2.0 12speed 12 Mb/s 12power 100mA 12chip-ID 8087:0026 12class-ID e001 12Hub-2 2-0:1 12info Super-speed hub 12ports 10 12rev 3.1 12speed 10 Gb/s 12chip-ID 1d6b:0003 12class-ID 0900 12Hub-3 3-0:1 12info Hi-speed hub with single TT 12ports 2 12rev 2.0 12speed 480 Mb/s 12chip-ID 1d6b:0002 12class-ID 0900 12Hub-4 4-0:1 12info Super-speed hub 12ports 2 12rev 3.1 12speed 10 Gb/s 12chip-ID 1d6b:0003 12class-ID 0900 12Device-1 4-2:2 12info Silicon Motion - Taiwan (formerly Feiya ) Flash Drive 12type Mass Storage 12driver usb-storage 12interfaces 1 12rev 3.1 12speed 5 Gb/s 12power 304mA 12chip-ID 090c:1000 12class-ID 0806 12serial <filter> 12Sensors: 12System Temperatures 12cpu 46.0 C 12pch 53.0 C 12mobo N/A 12gpu nouveau 12temp 41.0 C 12Fan Speeds (RPM) 12cpu 0 12fan-2 0 12Info: 12Processes 321 12Uptime 4m 12wakeups 254 12Init systemd 12v 250 12tool systemctl 12Compilers 12gcc 11.1.0 12Packages 12pacman 1173 12lib 328 12flatpak 0 12Client Unknown Client: systemd 12inxi 3.3.11

Are you using Prime and optimus manager? Maybe it’s similar issue to mine: Secondary monitor is dark after login - #9 by mskr

I had the same issue, I uninstalled optimus-manager and I am able to login successfully now

PS: its reinstall didn’t help, I have to keep it uninstalled only after the update

Oh my… That was it! Did not come to my mind as it was not part of the last updated packages. But, anyway, thank you :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.