Stuck on "... clean, ... files, ... blocks" on laptop screen at boot

I installed Manjaro KDE on my laptop yesterday. It was not my first time but it is the first time this happens to me.

Currently using Razer Blade 15 early 2019 with i7-8750H and RTX 2060. I completely removed Win10 from my laptop and am only using Manjaro. Could this have caused an issue?

When I boot, my laptop screen gets stuck here:

/dev/nvme0n1p2: clean, 903791/30121984 files, 28482075/120468837 blocks

If my external monitor is connected before I boot, I can use it. If I connect it after I boot, nothing happens. So, I have access to a DE, but of course I would like to use my laptop screen as well.

This happened right after I installed Manjaro, but I used Ctrl+Alt+F2 and then entered:

pacman -Syu

…rebooted and I had no issues. After turning on my laptop this morning, I am back to the same screen and there is nothing to update.

I tried using Ctrl+Alt+F2 to switch to tty2 and that worked.

Since there is nothing to update, I tried to manually start KDE with:

kstart5 plasmashell

…and I get this output:

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Aborted (core dumped)

Then I tried following the suggestion and reinstalling qt5-base and even installing qt6-base, but no effect. I also tried reinstalling xorg-server to no effect. I have tried using manjaro settings to switch between the different graphics drivers but none have a different effect. Exception is video-linux which doesn’t allow me to use external monitor at all.

The only aur packages I have installed are spotify, razer-laptop-control-git, and razer-laptop-control-dkms-git, firefox nightly. I also have MATLAB installed. I am not sure if this paragraph is relevant but I included it just in case.

Hello @dgtz :wink:

So i assume you get a screen output with video-linux. Do you have a a hybrid gpu laptop?

inxi -Gazy

If so, then the hdmi output could be managed by the nvidia gpu and not by the intel gpu, which will run by default.

This gpu is not supported by the open source nouveau driver. Therefore, you will need to use the nvidia driver.

Just a little explanation:

  1. Open Source driver: You have access to any output anytime, your gpu is NV160 and needs a lot of work: FeatureMatrix · So crappy support at the moment.
  2. You can use the nvidia driver as main and disable the intel driver, but this drain the battery more: HDMI should work this way.
  3. You can use the intel gpu and offload gpu intensive apps to the nvidia gpu with prime-run, but here you have not access to the hdmi port.
  4. optimus-manager is a tool to switch between 2 gpus. So if you need the hdmi output, you have to switch to the nvidia driver.
1 Like
  Device-1: Intel UHD Graphics 630 vendor: Razer USA driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300 
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Razer USA 
  driver: nvidia v: 460.67 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1f11 class-ID: 0300 
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 1-7:3 chip-ID: 13d3:56d5 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.9x11.9") 
  s-diag: 610mm (24") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") 
  diag: 609mm (24") 
  OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67 
  direct render: Yes 

This is with the external monitor connected. This is also with video-hybrid-intel-nividia-prime and linux-modesetting drivers installed in System Settings → Hardware Configuration.

1 Like

Yes, at the moment the nvidia driver is active and should display the desktop on:

Could you share your xorg configs?

for x in /etc/X11/xorg.conf.d/*; do echo -e "---$x---\n\n $(cat $x)\n\n"; done

However… i am not 100% sure, but it seems that on hybrid laptops, only the dGPU and therefore nvidia here is able to use the external port. There are restrictions of the nvidia driver because it is proprietary. It can only be used as main, or when using intel as main, you can offload to nvidia, but then you don’t have access to the nvidias external ports.

1 Like

I stumbled upon some sort of solution. I remembered that at some point during setting up nvidia drivers, I ran a command to generate a config file somewhere. So, I deleted/renamed:


Then switch to a terminal with Ctrl+Alt+F2 and ran:

sudo pacman -R xorg-server nvidia-utils sddm lib32-nvidia-utils linux510-nvidia linux54-nvidia linux59-nvidia nvidia-prime sddm-kcm


sudo pacman -S xorg-server nvidia-utils sddm lib32-nvidia-utils linux510-nvidia linux54-nvidia linux59-nvidia nvidia-prime sddm-kcm

I only wanted to uninstall then reinstall xorg-server, but everything else in the command was dependent on it so I threw 'em along too.

Rebooted. And I can use both, my laptop screen and my external monitor.

Here are the xorg configs after the uninstalling and reinstalling, but I don’t think there was a change:


# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "us"
    Option "XkbVariant" "altgr-intl"


 Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"


## Generated by mhwd - Manjaro Hardware Detection

I think the change occured in the /etc/X11/xorg.conf , but I can’t find the old file so I’m not sure what I had before.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.