Stuck in emergency mode

Manjaro boots to emergency mode, after system update.

It’s really urgent, coz I need this computer for study, I have an interview coming up, I really don’t want to reinstall manjaro right now

Things that I have tried

  • I’m not using Nvidia drivers, I have an amd system so it’s not a Nvidia issue

  • kernel version is 5.10,though that was booting to a blank black screen, I tried booting to fallback kernel 5.8, which boots me to emergency mode, here I tried updating grub, which for some reason removed windows entry from grub menu, and now it boots directly to 5.8, without asking, making things more frustrating

  • I tried updating system in emergency mode, as it gives me a terminal, but it doesn’t work, coz it isn’t connecting to internet and I don’t know how to connect to wifi with terminal
    Edit: I don’t think emergency mode allows networking, coz
    iw wlan0 info
    n180211 not found
    which, though I am not sure, may refer to my wifi card


have you read this?

I have, I can’t launch tty, as the system doesn’t boot fully, it used to boot to black screen
I used grub advanced options to get it to boot to emergency mode.

Now I’m trying to chroot in a live media and downgrade kernel to see if that helps.

But I’m getting another issue there,
mhwd-kernel - i linux54
Gives error: no targets specified

I tried installing grub and updating grub again, but it still wont detect windows

Also os-prober seems to giving errors, where it used to return name of os just a few seconds ago

sudo mhwd-kernel -i linux54
there is no space between - and i

Yeah yeah, I am typing this on a phone
But on laptop I did it correctly

In that case you should run from chrooted system:
sudo pacman-mirrors -f && sudo pacman -Syyu
and then try to install another kernel.

mhwd-kernel -li
Tells me I have 2 kernels installed 5.10 and 5.9,
But grub still detects 5.8 somehow even after updating it so many times and has made it default

I’m guessing that it isn’t installed and that’s why I get thrown in emergency mode, I managed to make grub always show grub menu so I can boot in 5.10

But this only partially solves the issue, the reason why I was trying 5.8 is because 5.10 and 5.9 both were booting to blank black screen

In the chrooted system

I did this, it updated pamac, but installing kernel still gives same error
no targets specified

I tried rebooting again, to 5.10, but it still gets stuck on Black screen. And 5.9 in emergency mode,

I still don’t understand why grub shows I have kernel 5.8 installed but mhwd doesn’t

This is taking too much time, I have to study, so I ll put this off, switch back to windows for a week till my interview then I’ll come back to it

Thank you for your time and help.
If you have any other idea, please keep posting, I’ll check this thread in my free time

I managed to fix it.
I was trying to install kernel using
mhwd-kernel -i linux54
Which is the command I read in manjaro documentation, to add new kernel,

but this was giving error
no targets specified

Later, someone on reddit suggested installing kernel via pacman,
pacman -S linux54

Which worked, and I was able to boot into the system via 5.4

Issues that still persist

  • I also tried reinstalling kernel 5.10 using pacman command above, but it still boots into a black screen,
  • kernel 5.8 still shows up in grub menu even though it isn’t installed, according to manjaro kernel settings and doesn’t show up anywhere else in the system.
    Updating grub doesn’t help, it somehow always finds 5.8 somewhere in the system

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.