Stuck in Emergency Mode after reinstalling kernel

I’m stuck in Emergency Mode after a strange series of events:
I suspended my system
When I tried to resume, it wouldn’t do anything, so after waiting for a while I restarted
Upon restarting, it would not boot
Pressing ESC I went into my grub menu, and tried the fallback
Fallback didn’t work, so I tried booting my second kernel
Second kernel worked!
Assuming something was wrong with the first kernel (primary 5.8, secondary 4.19), I reinstalled it
Something a bit odd happened here, grub-install created a second menu entry for Manjaro. The previous one just said “Manjaro”, and the new one had more stuff like which partition it was on.
Anyways, tried booting linux5.8, again, would not boot
Tried linux5.8 in second menu entry, no boot
Tried linux4.19, oh ****, now I’m in emergency mode

So I don’t know what happened, or why. Any help much appreciated!


So, I used manjaro-chroot -a to go in and reinstall (both) my kernels again, and my system is working now. I don’t understand what happened. I’ll post an update here if anything breaks again :laughing::sweat_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.