Stuck in emergency mode after kernel update

When I searched for updates, and saw that linux5.8 (which I was running) would be deleted, I decided to try to install linux5.10 first before doing the update.
I installed the new kernel, and everything seemed to go as normal.
So I rebooted my computer, and then, after selecting manjaro in grub (I have a dual boot with Win10), it would not boot.
I turned off and on my computer, and tried to select my old kernel (5.8) which was still there, and then was stuck in emergency mode.
Can someone help me get out of this situation?
(It might be useful to add that I have a NVidia graphics card)
Thanks again.

Yes, there was an issue. Is linux510 your only kernel? Can you reach to a TTY terminal with your system?

I pushed the needed updates to our repos, so going to a TTY via ctrl+alt+f3 and login with your root user should give you some options to fix this. sudo pacman -Syu should fix more updated packages I had pushed.

It is also good to know which Nvidia driver you had used before this update.

When I did the update, it seems to have also installed linux 5.4 (i think it’s an LTS) but upon trying to boot with it, it has the same issues as 5.10. The only kernel where I can get to what looks like a terminal (which says emergency mode) is 5.8. And for some reason, 5.7 still shows up in my grub menu (in Manjaro boot options) but I didn’t try to use it because I think I removed some time ago. But let me try booting 5.10 again and press ctrl+alt+f3 if that works and I’ll get back to you. Before updating anything, I was using the nvidia 455 proprietary drivers

So, ctrl+alt+f3 does work in 5.10, and I managed to log in my terminal. What should I do next?
(And sudo pacman - Syu failed, saying that it could not resolve any hosts to synchronize the databases. Is WiFi supported in this mode, or should I use a wired connection? Ok, just went for the wired connection)

wired connection should be fine. Wifi is not always given, especially when you not autoconnect to it. If you used the Nvidia 455 driver before, check if linux510-nvidia is installed. If it was Nvidia 390 it should be linux510-nvidia-390xx. An update should fix it normally. If not install them manually via sudo pacman -Sy <package name>. Output of mhwd and pacman -Q | grep nvidia should help. You can try also this:

  sudo mhwd -a pci nonfree 0300
  sudo mhwd -a pci nonfree 0302
  sudo mhwd -a pci nonfree 0380

Our wiki might help also: Configure Graphics Cards - Manjaro

It seems the update has solved all my problems.
Thank you very much for your help.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.