Stuck In Boot Emergency Mode

i didi everything correctly but this showing me how to fix this seems like failed to mount home folder

How to post required specs/logs from the terminal:

First install pastebinit:

sudo pacman -S pastebinit

Then run the important trobleshooting commands below (and post the outputs):

inxi -Fxxxz | pastebinit
sudo demesg | pastebinit 
sudo lsblk -f | pastebinit 

Enter the UUID for /home into /etc/fstab

Please post the links returned from the pastebinit commands on the forum.

How to enter UUID sorry im noob here??? @tbg

sudo lsblk -f | pastebinit

Please post the link returned from the pastebinit command on the forum.

:confused:sorry no help

This ^^^

Pastebinit not installing :frowning:

UUID=15475295-1a84-49f5-8fb3-8bf5148276d6 /                     ext4    auto,owner,rw,exec,suid,noatime 0 1
UUID=2aa21e7f-70b4-4c36-b48b-945fe652aed5 /home          ext4    auto,owner,rw,exec,suid,noatime 0 2
UUID=55d21db8-2ab4-423b-83c0-68d028432fa3 swap           swap    defaults,noatime 0 0

Above is my fstab.

Put your / home UUID from the output of "sudo lsblk -f" into your homes load lin in fstab.

UUID=PUT-YOUR-HOME-UUID-HERE /home          ext4    auto,owner,rw,exec,suid,noatime 0 2

Was this a working install that stopped booting. Or, is this a fresh install.

If new:

which ISO version
did you checksum the ISO
which utility did you use to burn the ISO to disk
have you installed this properly
perhaps do a single /root partition instead

Details, details, details!!!

howbto identify correct home UUID :frowning:

This is fresh install XFCE edition i didnt check checksum rufus dd mode used

It rather looks to me like you're using Antergos, not Manjaro. If you had been up front about this from the start I would have been inclined to help you. However, I do not enjoy helping deceptive individuals.

Adios.

1 Like

Sorry this is not antergos while ago i used it so that is the reason hard disk shows as antergos @tbg

  • The easy way:
sudo nano /etc/fstab

Navigate with arrows to the line with /home entry.
At the beginning of the line, add #like this

#UUID=   
  • Save, exit and reboot.
    Ctrl+O
    Ctrl+X
    Reboot

After booting to your system, find which partition is the proper "home" and edit your fstab with the proper partition UUID at /home entry.
Don't forget to remove the # from the beginning of the line.
Reboot after that. (because any user session changes will be lost after boot)

Probably irrelevant

Check if you can mount your home partition from a live usb. If you can't , It might be a corrupted EXT4 Filesystem for /home (happened to me with openSUSE recently, I heared it has something to do with GCC9, but im not sure about that).
The only way to fix it for me was fsck. fsck will restore your partition structure but may also destroy data on the partition: This means possible DATA LOSS and broken desktop environment configurations, etc.
Use this as your LAST option:

how to run fsck (VERY DANGEROUS, CHANCE OF DATA LOSS)

Note: replace /dev/sdxy with your home partition

sudo fsck.ext4 /dev/sdxy

If you CAN mount the filesystem from a live USB, be sure to back up your data as soon as possible!

EDIT:
To clarify: FSCK is not SO dangerous, just don't answer random prompts with yes if you don't know what you're doing.

can you boot USB install manjaro
open terminal

fdisk -l
inxi -Fxxxz

Are you sure you don’t have /home on your root partition?
If you don’t, I’d recommend what @DarkWav said, and grab a liveusb, boot into it, check which drive is your home partition. Hint: the drive containing Downloads, Pictures, Videos, Desktop is your home partition. Next grab the UUID for that drive and copy it. Finally chroot into your install, go to your fstab, input the correct uuid for /home, and perform an update. After that, reboot and your computer should boot fine.

Fsck is not very dangerous, in fact it is run every time you boot a Mac or Linux computer. All it tries to do is restore your filesystem. Only in very rare cases will FSCK damage your partition AFAIK.

FSCK f*cked up my KDE config on my home partition on openSUSE, that's why I warn people about it.
It did answer some fsck prompts with "yes", tho. If you dont't answer any prompts with yes its probably harmless.

but it doesn't seem to be the OP problem IMHO.
Have you read the OP posts? There is a broken entry in fstab (no UUID for /home)...
:man_shrugging:

1 Like