Stuck at windows switch screen


I am facing an issue with windows switch screen. Not sure whether this is the correct term or not, but here’s that screen:

Whenever I press the Windows button, these type of windows open. Until last week, i never faced any issues with it.

But now I cannot get out of this mode, almost 8 out of 10 times. My cursor still remains working,and I can close applications or click on the screen. But I cannot go inside any particular application. Even if I close all applications, I get an empty screen with the wallpaper, and can do nothing.

I found a thread saying it’s a known bug and Esc will solve the issue, but it doesn’t seem to work for me.

System Information:

  Kernel: 5.10.34-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=1970e90a-17a2-4823-a83c-78022d22ae51 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Portable System: Dell product: Inspiron 3543 v: A13 serial: <filter> 
  Chassis: type: 8 serial: <filter> 
  Mobo: Dell model: 04XW3R v: A00 serial: <filter> UEFI: Dell v: A13 
  date: 09/02/2020 
  ID-1: BAT0 charge: 4.8 Wh (33.8%) condition: 14.2/41.4 Wh (34.3%) 
  volts: 16.3 min: 14.8 model: SMP-SDI2.8 DELL FW1MN31 type: Unknown 
  serial: <filter> status: Charging 
  RAM: total: 7.69 GiB used: 2.31 GiB (30.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2F cache: 
  L2: 3 MiB bogomips: 17557 
  Speed: 906 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 906 2: 853 3: 890 
  4: 920 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon avx 
  avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de 
  ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d 
  fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid invpcid_single 
  lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx 
  pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 
  pti pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300 
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 
  vendor: Dell driver: N/A alternate: nouveau, nvidia_drm, nvidia 
  bus-ID: 08:00.0 chip-ID: 10de:1140 class-ID: 0302 
  Display: x11 server: 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting unloaded: intel alternate: fbdev,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.0.3 
  direct render: Yes 
  Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.34-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: Broadcom BCM43142 802.11b/g/n 
  vendor: Dell Wireless 1704 802.11n + BT 4.0 driver: wl v: kernel 
  modules: bcma port: 5040 bus-ID: 06:00.0 chip-ID: 14e4:4365 class-ID: 0280 
  IF: wlp6s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: 4000 bus-ID: 07:00.0 chip-ID: 10ec:8136 
  class-ID: 0200 
  IF: enp7s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Broadcom BCM43142 Bluetooth 4.0 type: USB driver: btusb v: 0.8 
  bus-ID: 1-1.6:7 chip-ID: 0a5c:21d7 class-ID: fe01 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 931.51 GiB used: 54.98 GiB (5.9%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS541010A9E680 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: A750 scheme: GPT 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD+-RW GU90N rev: A1B0 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 116.42 GiB size: 114.09 GiB (98.00%) 
  used: 16.93 GiB (14.8%) fs: ext4 dev: /dev/sda6 maj-min: 8:6 label: N/A 
  uuid: 1970e90a-17a2-4823-a83c-78022d22ae51 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.3 MiB (26.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 5289-4D21 
  ID-3: /mnt/common raw-size: 465.85 GiB size: 465.85 GiB (100.00%) 
  used: 30.37 GiB (6.5%) fs: ntfs dev: /dev/sda7 maj-min: 8:7 
  label: CommonStorage uuid: 6D3BCE480E618A66 
  ID-4: /mnt/main raw-size: 232.83 GiB size: 232.83 GiB (100.00%) 
  used: 7.66 GiB (3.3%) fs: ntfs dev: /dev/sda5 maj-min: 8:5 
  label: MainStorage uuid: DCE62DE9E62DC49C 
  Alert: No swap data was found. 
  ID-1: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/sda3 maj-min: 8:3 size: 115.81 GiB fs: ntfs label: Windows 
  uuid: 32B68F0BB68ECEB3 
  ID-3: /dev/sda4 maj-min: 8:4 size: 505 MiB fs: ntfs label: N/A 
  uuid: D2461D85461D6B8B 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s 
  chip-ID: 8087:8001 class-ID: 0900 
  Device-1: 1-1.6:7 info: Broadcom BCM43142 Bluetooth 4.0 type: Bluetooth 
  driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:21d7 
  class-ID: fe01 serial: <filter> 
  Device-2: 1-1.8:8 info: Realtek RTS5129 Card Reader Controller 
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129 
  class-ID: ff00 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 11 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 49.0 C mobo: 53.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 212 Uptime: 27m wakeups: 1 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 Packages: pacman: 1448 lib: 405 flatpak: 0 Shell: Zsh 
  v: 5.8 running-in: gnome-terminal inxi: 3.3.04 

Please let me know what I can do to fix this issue.


that’s gnome overview mode.
try disabling your dash-to-panel.
apps that are not fully compatible with gnome 40, can cause freezing.

Can you please tell me how to disable it? I’m afraid that I’m not very familiar with Manjaro, or Linux in general.

Most of the times, I was using Firefox and terminal only when it froze. I’d have expected these to support :frowning:

in the extensions app.
press super> type exten…
it should show.

Thanks, found and disabled. But how will it solve the problem of getting stuck at overview screen? It just disabled the bottom panel only, or that’s what it seems to me.

May be it does solve that as well somehow, but I’m not sure. Let me check for some more time to see if it gets frozen again or not.

There is a thread about a similar issue here, one of the solutions that was proposed was using the layout switcher to switch to a new layout and back again. So far one user reported this to be successful.

Hi Hanzel, thanks for the suggestion :slight_smile:

I tried that, and after that it didn’t happen again. I restarted my system 2 times and tested, and seemed to work as expected.

Will update if the issue comes back.

1 Like

Unfortunately, it happened again. I had to log out and restart my system to get out of it.

Layout information: I was initially on Traditional layout. Then switched to Manjaro yesterday. Now I switched it to Modern.

Yes, yarnabrina, unfortunately, i’m dealing with this bug since more than one month now.
The problem is that it happens randomly… If you find a way to reproduce this bug, i think that it could be very usefull.

I tried for last 3 days, and can’t reproduce. I tried with opening 2/3 applications after fresh login and pressing the Windows button, and replicating this quite a few times. Sometimes it freezes, sometimes it does not.

This is a very annoying, given I use this very frequently. Anyway, I’ve reset the settings by running dconf reset -f /org/gnome/ and switched to Traditional layout. The freeze rate seems to be low after this, but still happens occasionally.

Thank you for this solution !
I will try to do the same…
Hope that next update will help us…

I met the same problem dude, I am just trying to avoid using the win button