Stuck at login screen after entering password


I am a noob in Linux, i used it a long time ago in my programming school, but i mainly used bash for exercise and stuff. I didn’t do much more.

I still got that pc from school that i use almost everyday to watch series and stuff. Recently i tried to boot as usual and connected but the screen froze. Since then i am not able to boot on this computer.
The computer boot fines, when i get to the user login screen, if i fail the password, everything works fine too. But when i enter the right password the computer just freeze and won’t boot the session.

I looked for a solution but i’m still stuck. So far i managed to press E in grub and replace ‘quiet’ by ‘3’. I can login using my login and password, it boots in bash and i can travel throught the files.
I also tried booting ‘quiet s’ and check /etc/pam.d but i could not find any .pacnew in it.

I really need help i can’t do anything anymore :confused:

I assume you have seen the threads like this?

I see you got to runlevel 3 … but maybe check trying to start the desktop, or for failed services.

I looked for specifix thread so i didn’t see this one but in another thread i had the pacman -Syuu command but when i run it it says “error: failed retrieving file ‘multilib.db’ from XXXXXXX : Could not resolve host: xxxxxx”

I guess my computer is not connected to my internet box anymore but idk how to fix that with bash…

We dont know that for sure … runlevel 3 allows networking.
(you could check a few ways… ip a or ping etc)
You might just need to sort your mirrors:

sudo pacman-mirrors -g && sudo pacman -Syyu

Well i runned the pacman-mirrors command with -f3 and -g.
Didn’t fix my problem.
But as i said i can’t run pacman -Syyu.
How can i check my network?

But you didnt say you ran that.
You said you ran -Syuu (so please make sure to run with 2 y’s instead … also you should have been able to see when sorting mirrors if none of them were responsive)
I already provided 2 commands above to check if network is active.

Sorry i misstyped, i runned the right command “sudo pacman -Syyu” no Syuu.
The last message i get from that command is “failed to synchronize all databases”

When i run “ping” i get “ping: connect: Network is unreachable”
I am not able to understand what the “ip a” command shows me. Sorry to be so useless >.>

It does seem you have no network at the moment.
ip a should give you some output about your device(s) and state and such, for example UP or DOWN

wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000

Another is nmcli

Also is this wired or wifi ?

Wifi, yes i’m disconnected from internet rn. that’s what “nmcli” shows

Well if its working still it should be something like

nmcli d wifi rescan
nmcli d wifi list 
nmcli d wifi connect $YOUR_NETWORK_SSID

I solved while you sent your message by plugging ethernet cable, running Sudo pacman -Syyu. it asked if i should replace some library, i said y but didn’t have enough space. After that connecting to the session with ethernet cable worked.

The solution was just this easy… needed internet cable… Sorry for bothering and thanks for helping !

Then you need to do some cleaning to make sure you have enough space then do full updates … maybe even check logs (/var/log/pacman.log) for any botched transactions… otherwise I fear you are in a state of ‘partial-upgrade’ (broken).

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.