Stuck at Login Loop after latest update

While I was installing VirtualBox, i was offered to update,
Well, I did


But after restarting, error said, my system had a corrupted file system, and was asked to do fsck, I did, and selected default option for everything, which I shouldn’t have done.

Now, I’m unable to login, stuck in a login loop.

And while the update was going on I got this message, fixed that by following on screen instructions.

When I try to log in, I enter password, hit enter, then I am back to that screen after a few moments of black screen with boot messages.

Output of inxi -Fza using manjaro-chroot -a from live ISO USB

  12Kernel 5.15.6-2-MANJARO 12arch x86_64 12bits 64 12compiler gcc 12v 11.1.0
    12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro
    misolabel=MANJARO_XFCE_212RC1 quiet systemd.show_status=1 apparmor=1 security=apparmor
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  12Console N/A 12wm xfwm 12Distro Manjaro Linux 12base Arch Linux
  12Type Laptop 12System ASUSTeK 12product TUF Gaming FX505GD_FX505GD 12v 1.0 12serial <filter>
  12Mobo ASUSTeK 12model FX505GD 12v 1.0 12serial <filter> 12UEFI American Megatrends 12v FX505GD.304
    12date 01/30/2019
  12ID-1 BAT0 12charge 25.8 Wh (76.1%) 12condition 33.9/48.1 Wh (70.6%) 12volts 12.5 12min 11.7
    12model Simplo SDI ICR18650 12type Li-ion 12serial <filter> 12status charging 12cycles 41
  12Info 12model Intel Core i5-8300H 12socket BGA1440 (U3E1) 12note check 12bits 64 12type MT MCP
    12arch Coffee Lake 12gen core 8 12built 2018 12process Intel 14nm 12family 6 12model-id 0x9E (158)
    12stepping 0xA (10) 12microcode 0xEA
  12Topology 12cpus 1x 12cores 4 12tpc 2 12threads 8 12smt enabled 12cache 12L1 256 KiB
    12desc d-4x32 KiB; i-4x32 KiB 12L2 1024 KiB 12desc 4x256 KiB 12L3 8 MiB 12desc 1x8 MiB
  12Speed (MHz) 12avg 800 12min/max 800/4000 12base/boost 2178/8300 12scaling 12driver intel_pstate
    12governor powersave 12volts 0.8 V 12ext-clock 100 MHz 12cores 121 800 122 800 123 800 124 800 125 800 126 800 127 800
    128 800 12bogomips 36812
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  12Type itlb_multihit 12status KVM: VMX disabled
  12Type l1tf 12mitigation PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  12Type mds 12mitigation Clear CPU buffers; SMT vulnerable
  12Type meltdown 12mitigation PTI
  12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via prctl and seccomp
  12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization
  12Type spectre_v2
    12mitigation Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
  12Type srbds 12mitigation Microcode
  12Type tsx_async_abort 12status Not affected
  12Device-1 Intel CoffeeLake-H GT2 [UHD Graphics 630] 12vendor ASUSTeK 12driver i915 12v kernel
    12arch Gen9.5 12process Intel 14nm 12built 2016-20 12ports 12active eDP-1 12empty none 12bus-ID 00:02.0
    12chip-ID 8086:3e9b 12class-ID 0300
  12Device-2 NVIDIA GP107M [GeForce GTX 1050 Mobile] 12vendor ASUSTeK 12driver nvidia 12v 495.44
    12non-free 515.xx+ 12status current (as of 2022-06) 12arch Pascal 12process TSMC 16nm 12built 2016-21 12pcie
    12gen 1 12speed 2.5 GT/s 12lanes 16 12link-max 12gen 3 12speed 8 GT/s 12bus-ID 01:00.0 12chip-ID 10de:1c8d
    12class-ID 0300
  12Device-3 IMC Networks USB2.0 HD UVC WebCam 12type USB 12driver uvcvideo 12bus-ID 1-11:3
    12chip-ID 13d3:56a2 12class-ID 0e02 12serial <filter>
  12Display 12server X.Org 12v 21.1.1 12with Xwayland 12v 22.1.2 12compositor xfwm 12driver 12X
    12loaded modesetting,nvidia 12alternate fbdev,nouveau,nv,vesa 12gpu i915 12display-ID :0.0 12screens 1
  12Screen-1 0 12s-res 1920x1080 12s-dpi 96 12s-size 508x285mm (20.00x11.22") 12s-diag 582mm (22.93")
  12Monitor-1 eDP-1 12model Najing CEC Panda 0x002d 12built 2018 12res 1920x1080 12hz 60 12dpi 142 12gamma 1.2
    12size 344x194mm (13.54x7.64") 12diag 395mm (15.5") 12ratio 16:9 12modes 1920x1080
  12OpenGL 12renderer Mesa Intel UHD Graphics 630 (CFL GT2) 12v 4.6 Mesa 22.1.1 12direct render Yes
  12Device-1 Intel Cannon Lake PCH cAVS 12vendor ASUSTeK 12driver sof-audio-pci-intel-cnl 12bus-ID 00:1f.3
    12chip-ID 8086:a348 12class-ID 0403
  12Device-2 NVIDIA GP107GL High Definition Audio 12driver snd_hda_intel 12v kernel 12pcie 12gen 1
    12speed 2.5 GT/s 12lanes 16 12link-max 12gen 3 12speed 8 GT/s 12bus-ID 01:00.1 12chip-ID 10de:0fb9
    12class-ID 0403
  12Sound Server-1 ALSA 12v k5.15.6-2-MANJARO 12running yes
  12Sound Server-2 JACK 12v 1.9.21 12running no
  12Sound Server-3 PulseAudio 12v 16.0 12running yes
  12Sound Server-4 PipeWire 12v 0.3.52 12running no
  12Device-1 Intel Cannon Lake PCH CNVi WiFi 12driver iwlwifi 12v kernel 12bus-ID 00:14.3
    12chip-ID 8086:a370 12class-ID 0280
  12IF wlo1 12state up 12mac <filter>
  12Device-2 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12vendor ASUSTeK 12driver r8169
    12v kernel 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 1 12port 3000 12bus-ID 02:00.0 12chip-ID 10ec:8168
    12class-ID 0200
  12IF enp2s0 12state down 12mac <filter>
  12Device-1 Intel Bluetooth 9460/9560 Jefferson Peak (JfP) 12type USB 12driver btusb 12v 0.8
    12bus-ID 1-14:5 12chip-ID 8087:0aaa 12class-ID e001
  12Report rfkill 12ID hci0 12rfk-id 2 12state down 12bt-service N/A 12rfk-block 12hardware no 12software yes
    12address see --recommends
  12Hardware-1 Intel 82801 Mobile SATA Controller [RAID mode] 12driver ahci 12v 3.0 12port 5060
    12bus-ID 00:17.0 12chip-ID 8086:282a 12rev N/A 12class-ID 0104
  12Local Storage 12total 946.11 GiB 12used 104.96 GiB (11.1%)
  12ID-1 /dev/sda 12maj-min 8:0 12vendor Seagate 12model ST1000LM035-1RK172 12family Mobile HDD
    12size 931.51 GiB 12block-size 12physical 4096 B 12logical 512 B 12sata 3.1 12speed 6.0 Gb/s 12type HDD
    12rpm 5400 12serial <filter> 12rev SDM4 12temp 40 C
  12SMART yes 12state enabled 12health PASSED 12on 98d 4h 12cycles 2927 12read 3.66 TiB 12written 3.42 TiB
    12Pre-Fail 12attribute Spin_Retry_Count 12value 100 12worst 100 12threshold 97
  12ID-2 /dev/sdb 12maj-min 8:16 12type USB 12vendor SanDisk 12model Cruzer Blade 12size 14.59 GiB
    12block-size 12physical 512 B 12logical 512 B 12type N/A 12serial <filter> 12rev 1.00
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
  12ID-1 / 12raw-size 111.61 GiB 12size 109.3 GiB (97.93%) 12used 25.15 GiB (23.0%) 12fs ext4
    12block-size 4096 B 12dev /dev/sda9 12maj-min 8:9
  12ID-2 /boot/efi 12raw-size 513 MiB 12size 512 MiB (99.80%) 12used 300 KiB (0.1%) 12fs vfat
    12block-size 512 B 12dev /dev/sda6 12maj-min 8:6
  12ID-3 /home 12raw-size 126.95 GiB 12size 124.4 GiB (97.99%) 12used 79.81 GiB (64.2%) 12fs ext4
    12block-size 4096 B 12dev /dev/sda8 12maj-min 8:8
  12Alert No swap data was found.
  12System Temperatures 12cpu 47.0 C 12pch 54.0 C 12mobo 27.8 C
  12Fan Speeds (RPM) 12cpu 0
  12Processes 276 12Uptime 15m 12wakeups 1 12Memory 7.62 GiB 12used 3.04 GiB (39.9%) 12Init systemd 12v 251
  12default graphical 12tool systemctl 12Compilers 12gcc 12.1.0 12clang 13.0.1 12Packages 12pacman 1929 12lib 424
  12flatpak 0 12Client Unknown Client: systemd 12inxi 3.3.18

Tried pacman -Syyu, tried reinstalling KDE plasma, kernels, grub, but nothing seems to fix my problem

Help Please!


The problem was caused by my failing hard drive. After replacing it with a SSD. Everything is working fine and fast. Boot only takes about 4-5 seconds

Could be a failing hard drive, in which an update and/or reboot simply exposed the issue more overtly.

Run a short SMART selftest on your drive from a live USB session.

If it passes, run a long SMART selftest.

The 2.5-inch “laptop” drives fail more often than 3.5-inch form factors. They’re not built to last as long, let alone as rugged.

Caveat: Even a log SMART selftest will not reveal write issues.

Every test has PASSED

Your long SMART selftest finished in about 20 minutes?

Not sure, it just says, PASSED

One Thing I should have mentioned, I can login using tty2 and ofcourse manjaro chroot.

I can use all my cli application, compilers, games, i Can read write files using vim. Basically every non gui programs are usable. Maybe it is not a hard drive failure.

It doesn’t hurt to run the short and long SMART selftests, since you have access to the command-line (or even a live USB.)

The short test:

sudo smartctl -t short /dev/sda

When it finishes (maybe a few minutes), check the results with:

sudo smartctl -l selftest

sudo smartctl -l error

If no issues, next run the full extended test:

sudo smartctl -t long /dev/sda

This might take over an hour. You can check its progress with sudo smartctl -a /dev/sda

Then when it’s done:

sudo smartctl -l selftest

sudo smartctl -l error

If you don’t want to bother checking the drive (personally I would, since it’s a 2.5-inch laptop hard drive), then the least complex resolution is to re-install Manjaro from scratch (while preserving your user’s home folder / partition.)

Otherwise, you can attempt to force a full update from within the command-line again (which you said doesn’t even work.)

My earnest apologies, but it seems, long testing will need about 3 hours to complete, which I’ll not be able to wait, cause I need a working computer to work on assignments, which i must finish within 2 hours, so I think I will go in for doing fresh installation, keeping my home partition.

Do you have any suggestions for guides to follow doing it?
Though on the official wiki, there’s a mention of doing so,, but it’s a little bit confusing for me.

Choose the manual (“expert”) method when you get to the partitioning steps of the installer.

Make sure not to accidentally format or erase the disk!

Manually select your existing home partition, and tell the installer to mount it as /home without formatting it.

The only partition to format will be your root partition. (I.e, /)

Tread carefully, do not involve other partitions that might be part of a dual-boot, such as with Windows.

So I’ll leave windows partions as is.
Just the root, and home to be worked with, right?

Yes, but do not format home.

You’ll also need to select your existing EFI system partition (FAT32 format) and mount it as /boot/efi, but do not format it either.

I’d also advise you have a backup of your important files just in case.

Oh, and also…

DO NOT FORMAT YOUR EXISTING HOME PARTITION. (Only select it and choose to mount it as /home, but do not format it.)

Nothing worked. :pleading_face:

Had to go to the service center, seems my hard disk is malfunctioning. They told me, they will try recovering as much as data possible. But I now have to buy a new HDD or SDD.

That was my hunch, based on the fact that it’s a 2.5-inch HDD, and because you had filesystem corruption, and because there were sporadic issues. :frowning_face:

I hope you had an up-to-date backup of everything.

A long SMART selftest might have aborted early if it found an LBA error during the beginning of the test. (Rather than having to wait the full three hours.)

However, even if the SMART tests “pass”, it doesn’t mean your drive is fine, since they do not attempt to write data (only read.)

badblocks is another avenue one can pursue if they want to test reads and writes.

To end on this point: I always consider any data on a 2.5-inch HDD as unreliable for critical storage.

Always have more than one up-to-date backup of your important data elsewhere.

That hard drive lived enough, 2019-22.
It’s time to switch to a Nvme m2 ssd.

Some configs and ssh, php keys were backed up, more important files are backed up in cloud.

So no major loss hopefully.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.