stuck at first boot

#1

I just downloaded Manjaro-ARM Raspberry PI 3 LXQT, and flashed it to high speed SD card.
the boot stuck at line:

[ . 18.898957] fb0: switching to vc4drmfb from simple

#2

That usually happens when it can't detect the display correctly.

How is your monitor connected to the Pi?
HDMI -> HDMI
DVI -> HDMI (adapter/cable)
VGA -> HDMI (adapter/cable)

#3

It is connect HDMI -> HDMI

#4

Is it a standard HDMI cable?
It does not have any EthernetOverHDMI or anything like that?

#5

It is standard, with the same setup I was able to run RPi Rasbian, the only thing changed is flashing the SD card with manjaro arm.

#6

I just flashed another SD card with Manjaro ARM minimal, and it started normally, I'll try flashing the LXQT to the same flash and check

#7

Possible vc4 driver issue?
Suggest: blacklisting the vc4 driver

#8

Mmm, so what shall I do?

#9

How To blacklist: https://wiki.archlinux.org/index.php/Kernel_modules#Using_files_in_.2Fetc.2Fmodprobe.d.2F_2

Option 1
Create a '.conf' file inside '/etc/modprobe.d/'

example
/etc/modprobe.d/blacklist-vc4.conf

# Do not load the 'vc4' driver on boot
blacklist proper name of driver
blacklist associated drivers if required
#10

This assumes I'm already in, i.e. logged in, correct? can I do so at the img itself?

#11

same result, at both sd cards :frowning:

#12

My apologies, your working from an ISO image via SD Card.

You could "enable uart" via Serial Console and DVI monitor, or HDMI-input TV;
Not HDMI-to-DVI cable.

Also, this bug was fixed in Kernel 4.18.11-200.fc28.aarch64

#13

You should still be able to switch to another TTY (with CTRL+ALT+F2) to do this. The VC4 is the video card driver, which do not yet exist on the aarch64 platform.
So the rpi3 has the fbturbo driver installed instead.

Booting the rpi3 has always worked on my end, but maybe I was just lucky in my tests.

#16

mmm, after many trials, it worked, but did not show the desktop, and keep logging out to to the boot screen with the same error, then I've to keep using CTRL+ALT+F2. I think the image is not ready yet so will be back to Ubuntu till this issue is resolved.