Stuck after login without errors

Hi all,

yesterday i installed manjaro i3 on my computer and I have a weird problem. Directly after installation (first boot) everything is fine. Afterwards it is stuck after the login with a black screen. I can start startx in tty2. I tried the standard procedure pacman -Syyu but without success. I checked journalctl. There is something similar to an error

  • gkr-pam: unable to locate daemon control file

but I get the entry

  • Started Mark boot as sucessful

It seems unrelated to lightdm since I got the same issue with ssdm. It should be some configuration issue because after the first startup (some configuration is added/modified) I run into this problem.
Further information: I use a dual boot setup and I have a AMD Radeon R270X graphics card (often peope with similar problems had graphics driver issues).

Let me know if you need further information from me to help debug. Thank you in advance.

Hello,

Did a search on DDG for the error, Here is the Archwiki that has solutions.

https://bbs.archlinux.org/viewtopic.php?id=245171

Thank you,

I also found the page. But I thought it does not solve my problem because I do not have to unlock the key-ring by hand. After careful reading I unterstand that the error is most likely harmless.

https://gitlab.gnome.org/GNOME/gnome-ke … 9b67f1324a does not remove the error message
I think what the change does is when [1] [2] or [3] is reached the daemon will be started because need_daemon will now be set to 1.

My problem is that after login (lightdm) I am stuck at a black screen. I can switch to tty2 to login in via command-line and start startx myself then everything works fine.

You can clear this message by following the information I found. sp5100-tco sp5100-tco: Watchdog hardware is disabled [SOLVED]

Thank you. So it properly did not cause my problem.

I realized that the problem is I can only start startx as root. If I start startx without sudo I am again stuck at a black screen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark