Struggling to rebind caps lock in Gnome

I’m new to linux and at this point tried for hours to remap my capslock key to backspace I can’t figure it out. There are tons of different programs to do the same thing and access the same things in different ways. I can bind it but I don’t know how to make it persistent after rebooting. Is the best way to do this the .xinitrc file? if so how do I get whatever I use (xmodmap, setxkbmap, etc) to be called in the file? there’s a ton of stuff in the .xinitrc file by default where in that do I put it?

1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

:+1:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

Hi and welcome :wave:

There is a option in the tweaks tool to set it up in gnome.
Keyboard & mouseAdditional Layout options

  • Make Caps Lock an additional Backspace

(I’m not surprised that searching for this does not yield any good results, the tweaks tool does not have any documentation that I could find quickly and the options is hidden somewhat far away.)

2 Likes