Strange XFCE Desktop problem

No error message?
Would you like to try again?

xrandr --prop

Edit: Your nvidia seems to set monitor at 60…

Maybe some more info

cat ~/.xsession-errors
journalctl -b -p3
journalctl -b --user -p3

Thanks petsam for your prompt reply. I get this for xrandr

[andrew@andrew-pc ~]$ xrandr
bash: xrandr: command not found

Xsession errors

** (xfce4-session:790): CRITICAL **: 03:48:16.149: polkit_unix_process_set_property: assertion 'val != -1' failed
gpg-agent[827]: WARNING: "--write-env-file" is an obsolete option - it has no effect
gpg-agent: a gpg-agent is already running - not starting a new one

(xfce4-session:790): xfce4-session-WARNING **: 03:48:16.262: gpg-agent returned no PID in the variables

(xfce4-session:790): xfce4-session-WARNING **: 03:48:16.270: xfsm_manager_load_session: Something wrong with /home/andrew/.cache/sessions/xfce4-session-andrew-pc:0, Does it exist? Permissions issue?
dropbox: locating interpreter
dropbox: logging to /tmp/dropbox-antifreeze-CE9jbs
dropbox: initializing
dropbox: initializing python 3.6.7
dropbox: setting program path '/opt/dropbox/dropbox'
dropbox: setting home path '/opt/dropbox'
dropbox: setting python path '/opt/dropbox:/opt/dropbox/python-packages-36.zip'
dropbox: python initialized
dropbox: running dropbox
dropbox: setting args
dropbox: applying overrides
dropbox: running main script
dropbox: load fq extension '/opt/dropbox/cryptography.hazmat.bindings._constant_time.cpython-36m-x86_64-linux-gnu.so'

(wrapper-2.0:985): Gtk-WARNING **: 03:48:17.233: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner PulseaudioButton)
dropbox: load fq extension '/opt/dropbox/cryptography.hazmat.bindings._openssl.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/cryptography.hazmat.bindings._padding.cpython-36m-x86_64-linux-gnu.so'

(wrapper-2.0:968): Gtk-WARNING **: 03:48:17.553: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:1000): Gtk-WARNING **: 03:48:17.586: Negative content height -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner GtkButton)
weather-Message: 03:48:17.779: getting https://api.met.no/weatherapi/locationforecastlts/1.3/?lat=32.750161;lon=129.878100;msl=18
dropbox: load fq extension '/opt/dropbox/psutil._psutil_linux.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/psutil._psutil_posix.cpython-36m-x86_64-linux-gnu.so'

(xfdesktop:839): GLib-CRITICAL **: 03:48:17.874: g_base64_encode_step: assertion 'in != NULL' failed
dropbox: load fq extension '/opt/dropbox/linuxffi.pthread._linuxffi_pthread.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/tornado.speedups.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/cpuid.compiled._cpuid.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/linuxffi.resolv.compiled._linuxffi_resolv.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/linuxffi.gnu.compiled._linuxffi_gnu.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/linuxffi.sys.compiled._linuxffi_sys.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/librsyncffi.compiled._librsyncffi.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/posixffi.libc._posixffi_libc.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/PyQt5.QtWebKit.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/PyQt5.QtCore.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/PyQt5.QtNetwork.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/PyQt5.QtGui.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/PyQt5.QtWebKitWidgets.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/PyQt5.QtWidgets.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/PyQt5.QtPrintSupport.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/opt/dropbox/PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so'
xfsettingsd: Another instance took over. Leaving...

(xfdesktop:839): GLib-CRITICAL **: 03:48:21.645: g_base64_encode_step: assertion 'in != NULL' failed
conky: no process found
conky: Syntax error (/home/andrew/.conky/Gotham/Gotham:1: syntax error near 'yes') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: Invalid value 'yes' for setting 'use_spacer'. Valid values are: 'none', 'left', 'right'.
conky: desktop window (e00008) is subwindow of root window (1e6)
conky: window type - normal
conky: drawing to created window (0x4000002)
conky: drawing to double buffer
xfsettingsd: Another instance took over. Leaving...

(xfdesktop:839): GLib-CRITICAL **: 03:48:36.654: g_base64_encode_step: assertion 'in != NULL' failed
xfsettingsd: Another instance took over. Leaving...

(xfdesktop:839): GLib-CRITICAL **: 03:49:01.666: g_base64_encode_step: assertion 'in != NULL' failed
[1229:1229:0114/034916.071952:ERROR:x11_input_method_context_impl_gtk.cc(144)] Not implemented reached in virtual void libgtkui::X11InputMethodContextImplGtk::SetSurroundingText(const base::string16 &, const gfx::Range &)
[1229:1229:0114/034918.913956:ERROR:CONSOLE(6)] "Uncaught ReferenceError: gbar is not defined", source: https://clients5.google.com/pagead/drt/dn/ (6)
[1229:1229:0114/040433.927852:ERROR:CONSOLE(6)] "Uncaught ReferenceError: gbar is not defined", source: https://clients5.google.com/pagead/drt/dn/ (6)
[1229:1229:0114/040502.858239:ERROR:CONSOLE(6)] "Uncaught ReferenceError: gbar is not defined", source: https://clients5.google.com/pagead/drt/dn/ (6)

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.072: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.074: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.074: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.074: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.075: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.077: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.078: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.078: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.078: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.079: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.079: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.079: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.079: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.080: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.080: xfsm_client.c:builder_add_value: Value type not supported

(xfce4-session:790): xfce4-session-WARNING **: 04:13:27.080: xfsm_client.c:builder_add_value: Value type not supported
[1229:1229:0114/041357.923690:ERROR:http_bridge.cc(126)] Not implemented reached in virtual void syncer::HttpBridgeFactory::OnSignalReceived()
[2476:2476:0114/041430.303894:ERROR:x11_input_method_context_impl_gtk.cc(144)] Not implemented reached in virtual void libgtkui::X11InputMethodContextImplGtk::SetSurroundingText(const base::string16 &, const gfx::Range &)
[2476:2476:0114/041433.017380:ERROR:CONSOLE(6)] "Uncaught ReferenceError: gbar is not defined", source: https://clients5.google.com/pagead/drt/dn/ (6)
[2476:2476:0114/041914.229779:ERROR:http_bridge.cc(126)] Not implemented reached in virtual void syncer::HttpBridgeFactory::OnSignalReceived()
[3107:3107:0114/044027.014596:ERROR:x11_input_method_context_impl_gtk.cc(144)] Not implemented reached in virtual void libgtkui::X11InputMethodContextImplGtk::SetSurroundingText(const base::string16 &, const gfx::Range &)
[3107:3107:0114/044029.847850:ERROR:CONSOLE(6)] "Uncaught ReferenceError: gbar is not defined", source: https://clients5.google.com/pagead/drt/dn/ (6)

journalctl -b -p3

journalctl -b -p3
-- Logs begin at Wed 2019-01-02 13:23:09 JST, end at Mon 2019-01-14 04:45:51 JS>
-- No entries --

journalctl -b --user -p3
-- Logs begin at Wed 2019-01-02 13:23:20 JST, end at Mon 2019-01-14 04:40:26 JS>
-- No entries --

There are some suspicious errors in xsession-errors, I am not sure they are relevant though… but they could be…

Some xfce4 expert is needed!!

You may install xrandr (is useful either way)

sudo pacman -Syu xorg-xrandr

Thank you petsam. Here is the read out from xrandr:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080     60.00 +  59.94*   50.00    60.05    60.00    50.04  
   1680x1050     59.95  
   1600x1200     60.00  
   1600x900      60.00  
   1440x900      59.89  
   1440x480      59.94  
   1400x1050     59.98  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

This could be a theme issue as reported here
Please select Appearance -> Style -> Adwaita and reboot.

Why do you say that? What are the similarities to that one?

The error message is similar enough. I believe it doesn’t hurt to try :slight_smile:

Thank you swordfish. I changed the theme but it didn’t work.

Please, clear xfce4 sessions and set them to NOT be saved.

I think we can leave it for now, until you see future behavior.

Post back your findings.

Thank you petsam. Will do.

1 Like

I’ve done some more research into this problem and I think it is nvidia and its screen tearing fix that causes the problem: check here
In the thread there are different fixes, but I think I’ll stick with mine (change the display refresh rate from 60hz to 59.99hz) for the time being since I don’t have to change any files or add any start up scripts.
My nvidia driver is different to the one in the link posted above. Should I mark this as solved?

I guess so.
I am sure @korealinux @ottomops @maxf would like to know your finding and solution and might verify if it could also solve their issue (that topic is closed for new posts)

1 Like

Which menu setting is this?

Settings, Settings Manager, Display.

Ah I can’t change this setting for my monitor (there is only 1 option). It is already at 59.9 however.

Also I am not sure if this is the same problem. The thread you linked to is when Xfce boots to a black screen when ForceCompositionPipeline option is in xx-mhwd.conf (still booting to a black screen on Nvidia 415.25 for me). But you mention you can see your desktop background.

But I am still on Xfce 4.12.

Korealinux,
Yes, I can see my desktop background and mouse cursor. I do have the pipeline fix, though.

Hello andrewclive,

an alike problem I also had. If you have “Force Composition” enabled and change xfce display settings the error occurs at my machine.

Please take a look at ‘~/.config/xfce4/xfconf/xfce-perchannel-xml/’ . If there is a file called ‘displays.xml’ delete or rename it and restart.

You can also prove it, if it is this error when you lock your machine with ‘Ctrl-Alt-Del’ after first login. And when you login second time your desktop should shown up normaly.

Hope this helps your. :wink:

6 Likes

Thank you Kisun,
Yes, removing/ renaming ‘displays.xml’ does indeed fix the problem for me.
Thank you everybody for your help. I’ll mark this as solved.

Confirmed deleting ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml fixes booting to black screen on Xfce 4.12 using Nvidia Force Composition Pipeline. A reboot is required however, testing on the current session is not enough.

Also this fixes another related bug for me in using Compton in GLX mode. Before it would not work properly on login/boot and I had to work around it with another timed script.

:+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.