Strange Screen Tearing In manjaro xfce

Hey guys I am using Manjaro xfce
I came to figure an issue
which is of extreme screen tearing when I open my os



[ayushk@ayush-inspiron3541 ~]$ inxi -Fxz
  Kernel: 5.11.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: Xfce 4.16.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Portable System: Dell product: Inspiron 3541 v: N/A serial: <filter> 
  Mobo: Dell model: Inspiron 3541 v: A07 serial: <filter> BIOS: Dell v: A07 
  date: 11/27/2015 
  ID-1: BAT0 charge: 2.2 Wh (100.0%) condition: 2.2/41.4 Wh (5.3%) 
  volts: 17.0 min: 14.8 model: SMP-SAN2.8 DELL FW1MN41 status: Full 
  Info: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics 
  bits: 64 type: MCP arch: Puma rev: 1 cache: L2: 2 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 14379 
  Speed: 998 MHz min/max: 1000/1800 MHz boost: enabled Core speeds (MHz): 
  1: 998 2: 998 3: 1044 4: 1165 
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Dell driver: radeon 
  v: kernel bus-ID: 00:01.0 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 2-1.4:5 
  Display: x11 server: X.Org 1.20.10 driver: loaded: ati,radeon 
  unloaded: modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.11.6-1-MANJARO LLVM 11.1.0) 
  v: 4.5 Mesa 20.3.4 direct render: Yes 
  Device-1: AMD Kabini HDMI/DP Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus-ID: 00:01.1 
  Device-2: AMD FCH Azalia vendor: Dell driver: snd_hda_intel v: kernel 
  bus-ID: 00:14.2 
  Sound Server-1: ALSA v: k5.11.6-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: yes 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: e000 bus-ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Dell driver: ath9k v: kernel port: e000 bus-ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 2-1.2:6 
  Report: ID: hci0 state: up address: <filter> 
  Local Storage: total: 465.76 GiB used: 137.4 GiB (29.5%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  ID-1: / size: 450.35 GiB used: 137.4 GiB (30.5%) fs: ext4 dev: /dev/sda1 
  ID-1: swap-1 type: partition size: 7.21 GiB used: 0 KiB (0.0%) 
  dev: /dev/sda2 
  System Temperatures: cpu: 66.0 C mobo: 53.0 C gpu: radeon temp: 59.0 C 
  Fan Speeds (RPM): cpu: 4731 
  Processes: 208 Uptime: 58m Memory: 3.28 GiB used: 1.8 GiB (54.9%) 
  Init: systemd Compilers: gcc: 10.2.0 Packages: 1520 Shell: Bash v: 5.1.0 
  inxi: 3.3.03 
[ayushk@ayush-inspiron3541 ~]$ 

AMD drivers are built into the kernel and as you’re running a non-LTS kernel, you will every now and then run into issues like this, so install both 5.4 and 5.10 LTS and stay with those if it works flawlessly there.

For more information as to the why, please read this:

(especially the section about Linux kernels)

Installed both LTS kernel
5.4 and 5.10
and tried both
still facing the same error in both conditions

Does this also happen in a newly created user? (E.G. ayush222006-2)


Hello @ayush222006 ,

I’ve got no AMD processor or graphics but i’ve found this on internet. Maybe it can be a solution to your problem :


yeah it happens every time

I can’t help you any further then neither as I’m on nVidia and KDE and can only do basic AMD troubleshooting.


1 Like

We’re back to square one and this is not working any more.

Does anyone else have any bright ideas?

can you please guide me to some other solution
this solution worked at the beginning
but now it is not working now
I will be very glad if you give a small portion of your time in this problem
:grinning: :grinning: :grinning: :grinning: :grinning: :grinning:

i will be very thankful to you