Strange problems with desktop theme

I am having some strange problems with desktop theme being weird, Example:

Manjaro Settings Manager window is now white (was black) so i cannot see anything.

KMyMoney default white has now some black panels in places which again cannot see anything as the icon/text are in black.

Audacity also has a mixed white/black now, was all white before.

ckb-next also has black when it used to be white, so again cannot see the text.

I am using default Gnome theme in dark mode, with Legacy Apps theme set to Adwaita Dark, everything was normal before this update.

UPDATE: Fixed the issue by downgrading “qgnomeplatform-qt5” from 0.9.0-2 back to 0.8.4-4,
All is working normal again and no weird black/white mixed theme.

1 Like

I can’t reproduce it on three machines running GNOME, so it’s something on your end.

DISCLAIMER: Downgrading packages should only ever be temporary workaround, never a solution. Doing so is not supported and will cause issues down the road.

As it seems Arch has already updated to 0.9.0-3, i will wait for Manjaro to catch up and then try that version, FS-Uae launcher was the worst, everything was white so had to find a solution and this worked.

That was only a Qt 6.4 rebuild, that should make no difference.

Yes, I’m aware of the link to the Arch package.

I found this topic and tried everything/ever link, nothing worked until i downgraded back to the file still in my cache from before updating today, I am not using Wayland as I’m on Nvidia if that matters.

What does your /etc/environment look like?

cat /etc/environment

And if it exists:

cat ~/.profile
cat /etc/environment






cat ~/.profile

.profile: No such file or directory

<# = Hash, for some reason if i just copy and paste the text all hashes don’t show up and makes the text big and bold.

Also have tried hashing out QT_STYLE_OVERRIDE=“kvantum” and un-hashing QT_QPA_PLATFORMTHEME=“gnome” and also changed “gnome” to “gtk3”, Still the same problem with themes.

A reboot is required for changes to take effect. Neither value should be set while using QGnomePlatform.

I’ve fixed your post for you. Click the edit pencil icon and click Raw to review the changes. :wink:

See [HowTo] Post command output and file content as formatted text

Thanks for fixing the post and the link.

And yes i did reboot after every change i made, it was a long and boring process, but still the only fix seems to be downgrading qgnomeplatform-qt5, I also see timeshift is broken and needs a downgraded lib.

Hashing out QT_STYLE_OVERRIDE=“kvantum”, QT_QPA_PLATFORMTHEME=“gnome” and QT_AUTO_SCREEN_SCALE_FACTOR=1 and updating qgnomeplatform-qt5 is kind of working, KMyMoney is still a bit weird but text is readable, Manjaro Settings Manager is now all black with readable white text so that’s fixed but FS-Uae Launcher is still broken (as pictured), i don’t understand why downgrading qgnomeplatform-qt5 fixes all theme problems?

Is there anything leftover from a user theme in your ~/.config/gtk-3.0/ and/or ~/.config/gtk-4.0/?

gtk-3.0 has 3 files, Bookmarks, gtk.css, settings.ini, Bookmarks seems to be for file manager, gtk.css is empty (zero bytes) and settings.ini has 1 line “gtk-application-prefer-dark-theme=0”

gtk-4.0 has 2 files, gtk.css again empty (zero bytes) and settings.ini with the same “gtk-application-prefer-dark-theme=0”.

I think i’ve fixed FS-Uae Launcher, was a setting for FS launcher theme which was set to Fusion (Auto), which should choose between Light or Dark but for some reason fails to detect the right setting, so i changed the theme to Fusion-Dark and now it’s usable, picking any white/light theme in fs launcher settings will end up with the same problem as pictured above, still very confused as to why the older qgnomeplatform-qt5 works without problems but updated qgnomeplatform-qt5 is causing these problems, i hope the next update to qgnomeplatform-qt5 fixes these issues.

I still have to test more Apps but so far it’s kind of fixed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.