Strange problem with the internet and updating


Honestly, I don’t even know how to describe the problem… I’ve never had this. My internet seems to be working, I have a normal ping as usual, I can connect to some websites, but not all. For example on GitHub the page loads endlessly, the same for Discord (WEB version) or even this forum or YouTube. I have the impression that websites with dynamic content do not load. If I go to Wikipedia, everything works like a charm, but once I go to a site like this forum or DeepL, the HTML loads, but I can’t do anything. When I do a search on Google (Firefox) and I validate my request by pressing ENTER, it adds a new line to the search bar… If I try to update my system, I get the errors following (I’m French, so it’s translated into French on my system):

:: Synchronisation des bases de données de paquets…
 core est à jour
 extra est à jour
 community est à jour
 multilib est à jour
erreur : échec de récupération du fichier « core.db » depuis : Failed to connect to port 443 after 10000 ms: Couldn't connect to server
erreur : échec de récupération du fichier « extra.db » depuis : Failed to connect to port 443 after 10000 ms: Couldn't connect to server
erreur : échec de récupération du fichier « community.db » depuis : Failed to connect to port 443 after 10001 ms: Couldn't connect to server
avertissement : too many errors from, skipping for the remainder of this transaction
:: Début de la mise à jour complète du système…
 il n’y a rien à faire

However, I manage to download packages, I installed something randomly (speedtest-cli) and it works fine.

I have another computer which is also running linux, but running ubuntu. It has exactly the same problem, it “reassured” me and I thought that the problem came from my wifi rather than my pc. After several checks, however, the problem does not come from the wifi: I tried under Windows (no dual boot) and everything works fine. I also tried a bootable key, with an older version of Manjaro (6.1.30-1-MANJARO), internet and updates also work as expected. I then thought that the problem could come from the Linux kernel that I updated a few days ago on both computers (can’t remember when). So I used Grub to load an old kernel version (linux 5.15.122-1) but it didn’t change anything. So I’m currently back on linux 6.1.41-1.

Here is my system information, with inxi:

  Kernel: 6.1.41-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=68d2613f-d6dd-45e5-ad99-1647193dce85 rw quiet splash
    resume=UUID=8005aead-ec91-4419-9f77-1cf469793399 udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_wayland dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Notebook product: NP5x_NP6x_NP7xRNJ_RNH v: N/A
    serial: N/A Chassis: No Enclosure type: 10 serial: N/A
  Mobo: Notebook model: NP5x_NP6x_NP7xRNJ_RNH serial: N/A UEFI: INSYDE
    v: 1.07.04 date: 03/02/2023
  ID-1: BAT0 charge: 16.9 Wh (31.9%) condition: 52.9/54.8 Wh (96.4%)
    volts: 14.1 min: 15.4 model: Notebook BAT type: Li-ion serial: <filter>
    status: discharging
  Info: model: 13th Gen Intel Core i9-13900H socket: U3E1 bits: 64
    type: MST AMCP arch: Raptor Lake gen: core 13 level: v3 note: check
    built: 2022+ process: Intel 7 (10nm) family: 6 model-id: 0xBA (186)
    stepping: 2 microcode: 0x4112
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1924 high: 3000 min/max: 400/5200:5400:4100
    base/boost: 1980/5400 scaling: driver: intel_pstate governor: powersave
    volts: 0.7 V ext-clock: 100 MHz cores: 1: 462 2: 995 3: 429 4: 3000 5: 439
    6: 3000 7: 927 8: 3000 9: 636 10: 3000 11: 436 12: 3000 13: 716 14: 452
    15: 3000 16: 3000 17: 3000 18: 3000 19: 3000 20: 3000 bogomips: 119840
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: CLEVO/KAPOK
    driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
    ports: active: HDMI-A-1,eDP-1 empty: DP-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:a7a0 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: CLEVO/KAPOK
    driver: nvidia v: 535.86.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:25a2 class-ID: 0300
  Device-3: Bison BisonCam NB Pro driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-8:2 chip-ID: 5986:9102
    class-ID: 0e02
  Display: server: X.Org v: 23.1.2 with: Xwayland v: 23.1.2
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa dri: iris gpu: i915 display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 953x286mm (37.52x11.26")
    s-diag: 995mm (39.17")
  Monitor-1: HDMI-A-1 pos: bottom-l model: HP w2007 serial: <filter>
    built: 2007 res: 1680x1050 hz: 60 dpi: 99 gamma: 1.2
    size: 430x270mm (16.93x10.63") diag: 511mm (20.1") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  Monitor-2: eDP-1 pos: primary,top-right model: BOE Display 0x0a15
    built: 2021 res: 1920x1080 hz: 144 dpi: 128 gamma: 1.2
    size: 380x210mm (14.96x8.27") diag: 437mm (17.2") ratio: 16:9
    modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.0.4 renderer: Mesa Intel Graphics (RPL-P)
    direct-render: Yes
  Device-1: Intel vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:51ca
    class-ID: 0403
  API: ALSA v: k6.1.41-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.75 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 00:14.3
    chip-ID: 8086:51f1 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-1: Intel driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.02 TiB used: 101.36 GiB (9.7%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S1000G
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: SBM02103 temp: 43.9 C
    scheme: GPT
  SMART: yes health: PASSED on: 67 hrs cycles: 62
    read-units: 1,203,401 [616 GB] written-units: 1,839,171 [941 GB]
  ID-2: /dev/sda maj-min: 8:0 vendor: Generic model: Flash Disk
    size: 117.97 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter>
    fw-rev: 8.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 922.42 GiB size: 906.86 GiB (98.31%)
    used: 101.36 GiB (11.2%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 41.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 358 Uptime: 22m wakeups: 7 Memory: total: 32 GiB
  available: 31.06 GiB used: 3.78 GiB (12.2%) igpu: 64 MiB Init: systemd
  v: 253 default: graphical tool: systemctl Compilers: gcc: 13.1.1
  clang: 15.0.7 Packages: pm: pacman pkgs: 1253 libs: 378 tools: pamac,yay
  pm: flatpak pkgs: 0 Shell: Sudo (sudo) v: 1.9.14p2 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.28

Honestly, I don’t know what to do, especially since this problem occurs on two different computers that are not linked to each other. Which makes me think the problem is related to a distro-independent update, but I’m not sure.

Thank you for any help you could give me, if you need more information, ask me.

Hello @vanaur :wink:

Maybe the difference between Windows and Linux is just the DNS Cache. It looks like that your Public ISP DNS-Server is overloaded or throttle your requests.

You could try switching the DNS-Server. Like the one from Google or Cloudflare.

Hi @megavolt, thanks for your help :slight_smile: I’ve tried what you suggested on my two PCs, but unfortunately the problem persists…

I tried this server myself:

# ipv4 works:
ping -4 -c4
# ipv6 doesn't work:
ping -6 -c4

So the server has problems when connecting through ipv6.

Might not be related here, but check with ping for various websites when timeouts happen. Also ping your router.

Can you use ipv4? or is disabled on the router or by ISP?

I’ve tried the same pings as you, and I also get the same results. It works for ipv4 but not for ipv6. I’ve tried on other sites, the results are the same. I can ping my router for ipv4, but not ipv6, it doesn’t work either.

PS: I had entered a wrong ipv6 address for the router, in fact it works to ping the router in ipv6.

:point_up: :point_up_2:

Also did you happen to have installed a VPN? if so uninstall it again, then try again…

Hi @TriMoon, thank you for your reply :slight_smile: I don’t own a VPN, so I don’t think this applies to me.

However, I do have some good news! I was able to find the cause of the problem, which was actually twofold: following problems with my ISP, network outages corrupted updates I’d carried out earlier, the day before. I reinstalled the mirrors and updated my system with a stable connection. Then, the second problem was more subtle: in Firefox, one of my extensions had an update that conflicted with another extension, making it impossible to load certain pages. The extension in question is AdBlock. I deactivated it and installed Ultimate instead. Since both my laptops have Firefox on the same account, that’s make sense.

Everything’s back to normal… for now.

I apologize for taking up your time for something that had nothing related to Manjaro.

Hi @vanaur , thank you for your kind reply, may i inquire you about what software version you are? :face_with_hand_over_mouth:
(Maybe i need to update myself also)

Can you try to use some of the root DNS servers, which can be found here:

or the dns servers close to your location.

You could use pacman instead of pamac. And update your mirrors first, I guess that the Ukraine has other problems than server maintenance at the moment.

1 Like

Yes, of course. I hope you find this information useful:

$ cat /etc/lsb-release

As for Firefox, I’m using version 116.0 (64 bits) for Manjaro.

Hello @Keruskerfuerst, I’ve tried several of these DNS, and can’t really see any difference. Is it still useful, now that the problem seems to have been solved? Thanks!

It is always useful to give an AI more data input :wink:

1 Like

Just a helpful hint:
Dont use adware masquerading as adblock.
Use the true GOAT. ublock-origin
(the origin is important - Gorhill sold the original ublock many years ago … and the company turned it into … you guessed it … adware … so ublock-origin was created and maintained up to today)

1 Like

He is one of the few i rather call a “gifted” Asshole… (hes only one i blocked on GitHub, says enough)
I hate him deeply, but can’t deny the good stuff he makes occasionally.
(Even a broken clock shows correct time 2x day)

I had no idea about this, thanks for the information!

Never had that experience. Always seemed on-point … even auditing other things accurately, or in the case of ublock - resurrecting it for original fit and purpose.
But … all OT I suppose.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.