Strange log message

The log shows the following:

print_req_error: I/O error, dev sdd, sector 6293504
июл 10 10:52:40 roman-pc kernel: print_req_error: I/O error, dev sdd, sector 6293504
июл 10 10:52:40 roman-pc kernel: Buffer I/O error on dev sdd1, logical block 786432, async page read

But I do not have a sdd1 device!

sda      8:0    0 465,8G  0 disk 
└─sda1   8:1    0 465,8G  0 part /run/media/root/f9905890-7e3c-4f49-9c3c-f54bbca29357
sdb      8:16   0 931,5G  0 disk 
└─sdb1   8:17   0 931,5G  0 part /mnt/data
sdc      8:32   0 238,5G  0 disk 
├─sdc1   8:33   0   300M  0 part /boot/efi
├─sdc2   8:34   0   221G  0 part /
└─sdc3   8:35   0  17,2G  0 part [SWAP]
sr0     11:0    1  1024M  0 rom

What's happening?

Have you tried using the forum search function?

This post might help you:

My question is not about an error, but about a device that is not in the system. As you can see, error on sdd1 that is not in the system.

Could still be worth trying a different kernel and if that does not help then provide more info so that one of the forum experts can assist you.


I tried 4.14LTS and 4.19LTS.

  Host: roman-pc Kernel: 4.14.130-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.1.0 Desktop: Xfce 4.13.5git-94233b tk: Gtk 3.24.10 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: Z68P-DS3 serial: <filter> UEFI: American Megatrends 
  v: Ua6 date: 03/07/2013 
  Topology: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24880 
  Speed: 2631 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 2658 2: 2611 
  3: 2827 4: 1699 
  Device-1: NVIDIA GT218 [GeForce 210] vendor: ASUSTeK driver: nvidia 
  v: 340.107 bus ID: 01:00.0 chip ID: 10de:0a65 
  Display: x11 server: X.Org 1.20.5 driver: nvidia 
  resolution: 1280x1024~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: GeForce 210/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107 
  direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Device-2: NVIDIA High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0be3 
  Device-3: Texas Instruments PCM2902C Audio CODEC type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1.6:6 
  chip ID: 08bb:29c2 
  Sound Server: ALSA v: k4.14.130-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8168 v: 8.047.01-NAPI port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8190 802.11n PCI Wireless Network Adapter driver: N/A 
  port: c000 bus ID: 05:00.0 chip ID: 10ec:8190 
  IF-ID-1: enp0s26u1u5 state: unknown speed: N/A duplex: N/A mac: <filter> 
  Local Storage: total: 1.60 TiB used: 333.74 GiB (20.4%) 
  ID-1: /dev/sda vendor: Seagate model: ST3500418AS size: 465.76 GiB 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC38 scheme: MBR 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-00KUWA0 
  size: 931.51 GiB speed: 3.0 Gb/s serial: <filter> rev: 1H15 scheme: MBR 
  ID-3: /dev/sdc vendor: OCZ model: VERTEX4 size: 238.47 GiB speed: 3.0 Gb/s 
  serial: <filter> rev: 1.5 scheme: GPT 
  ID-1: / size: 216.51 GiB used: 76.19 GiB (35.2%) fs: ext4 dev: /dev/sdc2 
  ID-2: swap-1 size: 17.19 GiB used: 232.8 MiB (1.3%) fs: swap 
  dev: /dev/sdc3 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 41 C 
  Fan Speeds (RPM): N/A 
  Processes: 214 Uptime: 22m Memory: 15.63 GiB used: 1.99 GiB (12.7%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 clang: 8.0.0 Shell: bash 
  v: 5.0.7 running in: xfce4-terminal inxi: 3.0.34 

Hi nrw!
Did you check the hard drive for errors?
Is the HDD firmware up to date?
In my case I had to upgrade the firmware to fix this error.
Hope it helps

If you have any partitions on /dev/sdd listed in /etc/fstab, then add noauto,nofail to the mount options for those partitions ─ no spaces after the commas ─ and make sure that the two numerical fields at the end of the line for each of those partitions are set to "0".

Which log! Post the used command.

Maybe a usb plugged in gave this error as usb is always the last entry