Strange boot problem

Installed latest Manjaro KDE on a 12 year old Acer laptop with a single mbr hd and no option to change to uefi in bios. Managed to get it working after creating an efi boot partition. Strange thing is though when I reboot the computer I get nothing but a blank screen, no grub menu, no nothing. If I turn the laptop off though it boots just fine. Some facts:

Generated on 2020-09-22 18:18:1600791498
#################### inxi -Fxzc0 ########################
System: Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.5
Distro: Manjaro Linux
Machine: Type: Laptop System: Acer product: Aspire 5560 v: 0.1 serial:
Mobo: Acer model: Aspire 5560 v: A11 serial: UEFI: Phoenix v: 1.15
date: 12/05/2011
Battery: ID-1: BAT0 charge: 34.5 Wh condition: 34.5/48.8 Wh (71%) model: LION status: Full
CPU: Topology: Quad Core model: AMD A6-3420M APU with Radeon HD Graphics bits: 64 type: MCP
arch: Fusion L2 cache: 4096 KiB
flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 11981
Speed: 800 MHz min/max: 800/1500 MHz Core speeds (MHz): 1: 819 2: 801 3: 803 4: 801
Graphics: Device-1: AMD Sumo [Radeon HD 6520G] vendor: Acer Incorporated ALI driver: radeon
v: kernel bus ID: 00:01.0
Device-2: Alcor Micro Acer Integrated Webcam type: USB driver: uvcvideo bus ID: 2-3:3
Display: x11 server: X.Org 1.20.8 driver: radeon FAILED: ati unloaded: modesetting
resolution: 1366x768~60Hz
OpenGL: renderer: AMD SUMO (DRM 2.50.0 / 5.8.6-1-MANJARO LLVM 10.0.1)
v: 3.3 Mesa 20.1.7 direct render: Yes
Audio: Device-1: AMD BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G series]
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:01.1
Device-2: AMD FCH Azalia vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus ID: 00:14.2
Sound Server: ALSA v: k5.8.6-1-MANJARO
Network: Device-1: Broadcom and subsidiaries NetLink BCM57785 Gigabit Ethernet PCIe
vendor: Acer Incorporated ALI driver: tg3 v: kernel port: 2100 bus ID: 01:00.0
IF: enp1s0f0 state: down mac:
Device-2: Broadcom and subsidiaries BCM43227 802.11b/g/n vendor: Foxconn driver: wl
v: kernel port: 2100 bus ID: 02:00.0
IF: wlp2s0 state: dormant mac:
Device-3: NetGear WNA3100M(v1) Wireless-N 300 [Realtek RTL8192CU] type: USB
driver: rtl8192cu bus ID: 2-2:2
IF: wlp0s19f2u2 state: up mac:
Drives: Local Storage: total: 126.11 GiB used: 9.88 GiB (7.8%)
ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 120GB size: 111.79 GiB
ID-2: /dev/sdb type: USB vendor: SanDisk model: Ultra Fit size: 14.32 GiB
Partition: ID-1: / size: 63.81 GiB used: 9.88 GiB (15.5%) fs: ext4 dev: /dev/sda4
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 64.0 C mobo: N/A gpu: radeon temp: 41 C
Fan Speeds (RPM): N/A
Info: Processes: 167 Uptime: 14m Memory: 3.33 GiB used: 641.3 MiB (18.8%) Init: systemd
Compilers: gcc: 10.2.0 Packages: 1201 Client: KDE Plasma v: 5.19.5 inxi: 3.1.05

Disk /dev/sda: 111,79 GiB, 120034123776 bytes, 234441648 sectors
Disk model: Samsung SSD 850
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xf4c9408d
Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 337919 335872 164M b W95 FAT32
/dev/sda2 337920 430079 92160 45M 7 HPFS/NTFS/exFAT
/dev/sda3 430080 97421311 96991232 46,2G 7 HPFS/NTFS/exFAT
/dev/sda4 97421312 234440703 137019392 65,3G 83 Linux

Welcome at the forum, @CGA
What I not understand is why you did not try to install Manjaro in BIOS (legacy) mode on your msdos parted disk? Booting into live USB stick in BIOS mode usually should allow you to do this. :thinking:

My goal was initially to dual boot with win10 and when changing to mbr in the installer I got a warning that it would overwrite the current mbr containing w10:s boot. That goal is now thoroughly out of the window :laughing:.


… which would be no problem at all. BIOS will boot into Manjaro’s grub and after

sudo update-grub

and a reboot you usually get the boot entry for Windoze. :tada:

The warning message was maybe a bit overly scary then. Btw I just checked booting from the Manjaro usb stick which was created with Rufus in bios/mbr mode and it has exactly the same problem, laptop has to be turned off for it to work.

Yes, as for BIOS/MBR systems that’s the most recommended procedure for a dual boot install.

I’ve never heard of a similar case. :thinking:

Me neither. I’m obviously not alone though. Tried several of his solutions but nothing worked.

Yup: known bug in the Acer UEFI firmware. some even don’t shut down without a key press.

Unfortunately Acer is not the best in providing firmware updates so:

  • Learn to live with cold boots
  • Never buy another Acer any more (and my solution to the same problem)


I can assure you, that is never going to happen again.

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.