Strange behaviour with kernels!?or something else!

Tried using 5.8 kernels in Manjaro…but problems every time…even if I can use 5.8, sometimes when rebooting it gets stuck with black screen with motherboard logo!

So I tried arch…with 5.8.10 and 5.8.11(updated yesterday)
Everything working perfectly…not a single problem

So why I was facing issues with Manjaro!!??
Is this a driver or software conflict or something else??!!

1 Like

Well, Manjaro’s 5.8 kernel currently still sits at 5.8.6 for the Stable branch, whereas the Arch kernels you’ve tried are newer ─ Arch is much more bleeding edge than Manjaro Stable, and the closest thing we have to that is Manjaro Unstable.

The bottom line is that you may indeed have stumbled upon a bug in Manjaro’s current 5.8 kernel. But this should then be remedied when the next Stable update arrives, which won’t be long anymore. (Don’t ask when ─ it’ll be ready when it’s ready. :wink: )

Thanks for replying :smiley:

I switched to manjaro testing today and installed 5.8.11

Bt with no luck!:pensive::pensive::pensive:
Same issue

I really want to use manjaro with latest kernels (I understand I don’t need the latest version…lts is fine for me…but I want to use the latest kernels with Manjaro)

Well, without proper information regarding your hardware, I doubt whether there’s anything anyone can do. And if there’s a proprietary Nvidia driver involved, then all bets are off, because proprietary drivers cannot be debugged by the community.

If you really insist on running the latest kernels ─ although I cannot see why ─ and you want more help, then you’re going to have to give us more information, like for instance the output of the following command… :arrow_down:

inxi -Fxxxza

this is a week old…saved this

  Kernel: 5.4.64-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MANJARO_GNOMEM_201 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor 
  Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: Intel model: DH61HO v: AAG62445-102 serial: <filter> 
  UEFI: Intel v: HOH6110H.86A.0816.2018.1031.1524 date: 10/31/2018 
  Topology: Quad Core model: Intel Core i7-3770S bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 20 
  L2 cache: 8192 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 49509 
  Speed: 1597 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1596 2: 1596 
  3: 1596 4: 1597 5: 1597 6: 1597 7: 1594 8: 1597 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; 
  SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ZOTAC driver: nvidia 
  v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c82 
  Display: x11 server: 1.20.8 compositor: gnome-shell driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
  Device-2: NVIDIA GP107GL High Definition Audio vendor: ZOTAC 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Sound Server: ALSA v: k5.4.64-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Intel driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB 
  driver: r8188eu bus ID: 1-1.1:3 chip ID: 0bda:8179 serial: <filter> 
  IF: wlp0s26u1u1 state: down mac: <filter> 
  Device-3: TP-Link UE300 10/100/1000 LAN (ethernet mode) [Realtek RTL8153] 
  type: USB driver: r8152 bus ID: 4-3:2 chip ID: 2357:0601 serial: <filter> 
  IF: enp4s0u3 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 1.93 TiB used: 111.58 GiB (5.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: KC45 scheme: GPT 
  ID-2: /dev/sdb vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: 023 scheme: GPT 
  ID-3: /dev/sdc type: USB vendor: Seagate model: BUP Slim BK 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  serial: <filter> rev: 0304 scheme: MBR 
  ID-4: /dev/sdd type: USB model: TO Exter nal USB 3.0 size: 111.80 GiB 
  block size: physical: 4096 B logical: 512 B serial: <filter> rev: 0204 
  scheme: GPT 
  ID-1: / raw size: N/A size: 11.70 GiB used: 559.9 MiB (4.7%) fs: overlay 
  source: ERR-102 
  Alert: No Swap data was found. 
  ID-1: /dev/dm-0 size: 1.85 GiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-2: /dev/sda1 size: 465.76 GiB fs: ntfs label: New Volume 
  uuid: A67ACCA77ACC7599 
  ID-3: /dev/sdb1 size: 100.0 MiB fs: vfat label: SYSTEM uuid: CCB8-59E3 
  ID-4: /dev/sdb2 size: 391.96 GiB fs: ntfs label: N/A 
  uuid: ACA0ECC1A0EC92DE 
  ID-5: /dev/sdb3 size: 505.0 MiB fs: ntfs label: N/A uuid: 80580F7C580F7068 
  ID-6: /dev/sdb4 size: 73.21 GiB fs: ext4 label: N/A 
  uuid: c76655e4-412f-4e7c-bcc6-c990096661de 
  ID-7: /dev/sdd1 size: 111.76 GiB fs: exfat label: Ventoy uuid: 4E21-0000 
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 38 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 49% 
  Processes: 240 Uptime: 1m Memory: 15.60 GiB used: 839.7 MiB (5.3%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1021 lib: 280 
  Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.05

Well, there you have it… My words aren’t even cold yet. :frowning_face:

:pensive: :pensive: :pensive: :pensive: :pensive: :pensive: :pensive: :pensive:

so it might b a driver issue?? :pensive:

I’m afraid so. There have recently been some changes upstream ─ meaning with the development of the Linux kernel itself ─ with regard to how the Nvidia driver must interface with the kernel, and we’ve been seeing lots of stability problems since then. :man_shrugging:

1 Like

not buying nvidia cards again
they should open source their drivers

btw thanks for helping :smiley:

with arch I installed nvidia drivers too

Oh, I absolutely agree, and I too am not buying Nvidia anymore. My previous computer had an AMD GPU, and this one here has an Intel GPU. Works like a charm. :wink:

My advice to you would be to stick to the 5.4 LTS kernel with that machine. It’s not a very recent machine, and the 5.4 LTS kernel would be better suited for that hardware. :wink:

My own machine is more recent than yours, and I too am running the 5.4 LTS kernel. It’s rock-solid. :slight_smile:


yup… lts is the way 2 go :smiley:

1 Like

both arch and manjaro had nvidia driver installed with kernel 5.8.11…
so why arch is working fine and manjaro isn’t??

is there any new intel microcode update or something like that?

Well, the Manjaro kernels are compiled by the Manjaro developers and have some Manjaro-specific settings and patches. They are not the same as the Arch kernels.

I don’t think it’s the microcode, because Manjaro Unstable is on par with Arch Stable, and the intel-ucode package currently stands at the same version across all three Manjaro branches. :man_shrugging:



I’m staying on lts :smiley:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.