Stop dolphin from defaulting settings

Every time when I boot dolphin resets its settings which is annoying. How do I stop it from doing that. What I want to happen is every time I load dolphin I want it to go to my home directory, not the last directory I was in. I know I can set it in settings. Every time I keep going here and switching it out and clicking apply which is annoying.

Have you checked the settings in Manjaro Settings Manager > Start and shutdown > Desktop session

Set it to start with empty session

(Wording could be slightly different as the above has been translated from my language)

I’m sorry I don’t see a thing in settings manager
Have a look

Thats manjaro settings manager. “MSM”
It is embedded in, but not the same as, “System Settings” from KDE/Plasma.

@Wollie wording was misleading as they guessed.

Here is my reference:

System Settings  > Workspace > Startup and Shutdown > Desktop Session

Unfortunately, changing that in the settings did nothing. Dolphin still goes to the previous location I was at not the home directory. Also, some shortcut keys don’t get saved either, for example, ctrl + alt + T to open the terminal always gets reset and set to nothing which is annoying and some of my custom ones also get reset too.