SteamPlay won't launch games

I click for Doom, play, it says “running” and does absolutely nothing.
Or: quake champions sends me to error report.

Have a look here>
Proton & Doom
See what other people have been doing to get it working.

Preparing…
Cloning proton build files…
Checking proton dependencies…
Cloning wine-valve-git build files…
Checking wine-valve-git dependencies…
Building wine-valve-git…
==> Making package: wine-valve-git 3.16.r203.g174d487bf8-1 (Tue 05 Feb 2019 05:11:40 PM PST)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Updating wine-valve-git git repo…
Fetching origin
-> Found harmony-fix.diff
-> Found 30-win32-aliases.conf
-> Found wine-binfmt.conf
==> Validating source files with sha256sums…
wine-valve-git … Skipped
harmony-fix.diff … Passed
30-win32-aliases.conf … Passed
wine-binfmt.conf … Passed
==> Removing existing $srcdir/ directory…
==> Extracting sources…
-> Creating working copy of wine-valve-git git repo…
Cloning into ‘wine-valve-git’…
done.
Checking out files: 72% (5581/7666)
Checking out files: 73% (5597/7666)
Checking out files: 74% (5673/7666)
Checking out files: 75% (5750/7666)
Checking out files: 76% (5827/7666)
Checking out files: 77% (5903/7666)
Checking out files: 78% (5980/7666)
Checking out files: 79% (6057/7666)
Checking out files: 80% (6133/7666)
Checking out files: 81% (6210/7666)
Checking out files: 82% (6287/7666)
Checking out files: 83% (6363/7666)
Checking out files: 84% (6440/7666)
Checking out files: 85% (6517/7666)
Checking out files: 86% (6593/7666)
Checking out files: 87% (6670/7666)
Checking out files: 88% (6747/7666)
Checking out files: 89% (6823/7666)
Checking out files: 90% (6900/7666)
Checking out files: 91% (6977/7666)
Checking out files: 92% (7053/7666)
Checking out files: 93% (7130/7666)
Checking out files: 94% (7207/7666)
Checking out files: 95% (7283/7666)
Checking out files: 96% (7360/7666)
Checking out files: 97% (7437/7666)
Checking out files: 98% (7513/7666)
Checking out files: 99% (7590/7666)
Checking out files: 100% (7666/7666)
Checking out files: 100% (7666/7666), done.
==> Starting prepare()…
patching file dlls/gdi32/freetype.c
Hunk #1 FAILED at 996.
Hunk #2 FAILED at 7271.
Hunk #3 FAILED at 7357.
Hunk #4 FAILED at 7439.
4 out of 4 hunks FAILED – saving rejects to file dlls/gdi32/freetype.c.rej
==> ERROR: A failure occurred in prepare().
Aborting…

Bump bump

why are you using aur for wine dont install using aur

use steam-manjaro and there play it

Okay. I only tried to use AUR because Steamplay was not working properly

Doom is not working at all.
Quake Champions is not working.
Realm Royals is not working.

Did you install any custom steam packages?

If not, you might want to try deleting the current steam install and letting steam re-install itself.
Delete the following:
(if you have games downloaded, move ~/.local/share/Steam/steamapps somewhere else before deleting, so it can be moved back and you won’t have to re-download your games)

~/.steam
~/.steampath
~/.steampid
~/.local/share/Steam

After that, launch steam (close steam after logging in, move the steamapps folder back if you moved that previously, then relaunch it) and see if the issue persists.

1 Like

Steam-Mankato
Or Steam-Native

I use steam-native, but the default steam-manjaro should work as well. If you install the native version, that needs to be installed alongside steam-manjaro.

So uninstall Steam-Manjaro

Then in order to install steam-native
I need to install steam-Manjaro

Yes. You need steam-manjaro installed regardless.

Okay. So do you prefer after installing… to only use steam native

install steam native and from repo install wine-staging and all optional dependancies
also install xorg-apps
these are must have for gaming
also install tlpui and tune it to performance

Thank You!!! Wine staging installs

But need I install proton or nah?

wine-staging is not needed to get proton games working in the native Steam client. However, I agree that it is a good idea to install this. Some of its dependencies might be used by the steam client when you use steam-native.

Proton is built into steam

no need as steam-native has proton
wine-staging is needed for all optional dependancies that are not listed in steam-native

Thank you two. I know nothing of Arch Linux at all. And I have an HD Radeon 5770

YO! I am impressed!
Realm Royale was able to play with all qualities on maximum and no lag!
Windows 10 could not even accomplish this!
I am still having the same problem with Doom though. I click play, and it says, “running.” But, it does nothing and then the “running” single gets removed.

Quake Champions i read is not using linux friendly drivers. so quake champions is understandable. All it does is a black screen and then an error report.

i have to be specific i tried to play DOOM (2016) demo and i found out it is not whitelisted.
… but anyways quake champion says this after the black screen window

Adding process 9724 for game ID 611500

Adding process 9725 for game ID 611500
amdgpu_device_initialize: DRM version is 2.50.0 but this driver is only compatible with 3.x.x.
amdgpu_device_initialize: DRM version is 2.50.0 but this driver is only compatible with 3.x.x.
ERROR: ld.so: object ‘/home/username/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so’ from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Setting breakpad minidump AppID = 611500
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198892859031 [API loaded no]

Adding process 9728 for game ID 611500

Forum kindly sponsored by Bytemark